summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/python-glanceclient
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest4
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild78
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index a1d643336ff7..148282798508 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-2.13.1.tar.gz 187298 BLAKE2B e2fa34ea7840404e183fbb77592f656b296d54942581b2e1dda71285f791cf7f7d5b3b6ef2da28deb4e314f1d35395548e923f548854b7ad3ef4aa50ad000d62 SHA512 deb8454aea8b2c231604663fac2f6515e3cd6e86dc1cf3cd2174ba2e35f9d605bf162f5a089d80f52da11f97c540f5c160b96864b85d7535463ec170cba81689
-EBUILD python-glanceclient-2.13.1.ebuild 2484 BLAKE2B 8b0b9a1b1cf71ff97a14830904378c24fc804f853f7364c4affbd0b1146ee5ca2acb67d8732f96df05892b4b63533df8f7bffca3244f150a14ead5d8be5c1f36 SHA512 13d5ff8a5138eaf371c22f1dd7abed5f39843c01cbf82b07e614de319e8812cbf23408bd73aae4bb7e44de1696f170eff9f428edfbc3e4860c68db5a8e45555c
+DIST python-glanceclient-2.16.0.tar.gz 189395 BLAKE2B 9de8b162c1eb5bfb44700f41cbdcd4f8a983d8c7bd7b281df09db67df6a0de5dee905330f03c967be9e1c3b2aaa379e4c8594f7f4cdbb34870a1e87cb7ccaf1f SHA512 b853f529752247873d9f319d4ec6f4cabc89ee4c26a0c1013e7609fc38e3c9f68d774b3682166e8155e21572a0a011eb6859a84c253ca9f7a9b8b1ccf79b5322
+EBUILD python-glanceclient-2.13.1.ebuild 2482 BLAKE2B 4e81e78d4e40a6d9e7913b5215dd721cf05554f57978ebad3f5b061d8d08e1e129f47b2934473885dbb51a07530adaaaee2591290cda6ea4fd4cd3e6846a6495 SHA512 6d07c1d89f6178098a67a8c9a62df65971ab6dd69c6cdecc3ca20e7212794b7b62f83de3fdcb1559fb5c5a0722525b1b8dbb4f708cabd178896b275cf5a87b25
+EBUILD python-glanceclient-2.16.0.ebuild 2486 BLAKE2B ebb0b0900de23049d07a92f46033bc6e0cd7db6bafe0fff0bc3a1a7ae47182eb2ec50fb2cd6d7d73ae7537f907986390e32a42c4f9b22830fbadfda33e8c6765 SHA512 934d43b4e5ebaf498dfa9a02ae9155e0251b24a269cd826d6b1de89ef1000ca8b479d8a55f81f7b0b2254d15779560c4b87f6948669812ce4fe1744cb28e8f7c
MISC metadata.xml 632 BLAKE2B 69885578505253d6ec3d0245779a89ebe5c75ab8a8e9fecbf95c29d4aa17ba6864e69c1806a01cde0e92080a86ccbae146bdb2c003f50fd3dfd32b6d2186536f SHA512 d807a9aadecb131f92d6a476a8bc0b0293d46c6ac761a2d1ddb596ac219c6c8ac349402e3f56d150e78ad81c5d2838a33b3d35222a18f9a416f969f6d6208d8f
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
index 6a318ce6e77d..1b8c2685a8bd 100644
--- a/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
inherit distutils-r1
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
new file mode 100644
index 000000000000..9795334878a9
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ordereddict-1.1[$(python_gen_usedep 'python2_7')]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}