summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /dev-python/python-glanceclient
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.10.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 9846d1da4ba5..95932a493685 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,5 +1,7 @@
+DIST python-glanceclient-2.10.0.tar.gz 180299 BLAKE2B 0d97626361ad7fc2c688f5da6af6d49bf6e078f715560b4ac93725f8ea6df895e7eed0e44bf69399c973978af22ebaef3d371ae19026cff7fb2bd896c8be30d2 SHA512 9132493559d7a7b6de62e5ec1bdcd7a2dcf408c00bb0cfaccb6e11829975d468bfe68feabd71fdf8cc0d28a2c5c549945816aa14c9469314ffafd3d39b9c2da6
DIST python-glanceclient-2.8.0.tar.gz 177172 BLAKE2B 0772b7e2b788b63bb590c8354dbad2c4e0bbd731f790f36916aeb154a44474f979961195d307e45149bccd2a58e1df72c48aa0593d6972c606b393f1202ee440 SHA512 257eaf1d548a3a6277b9c80e8b23b9ae4231586307c43a064754c227f3e3c872451ec0469aca931638ea0f7c9920892878c677b144dc72bad215c38d375a63d3
DIST python-glanceclient-2.9.1.tar.gz 175836 BLAKE2B f559bff0b4ae1d1782bb06f9bb8b0188d9e78b83afb52a07245f8d9694bfe88e52718d3279f8b2b7d32acdd3cc86d507154bc9bcf716206696144345f4766249 SHA512 0dae48a5673ed779c0a4136896f5e74dcde489a5dfee55295f65d4b74dbe4680b1669570d0fe5011ca5282d0b6057ebc9261e5a06cff0b09fe41fa88529c3947
+EBUILD python-glanceclient-2.10.0.ebuild 2443 BLAKE2B 7e026fa4c173c8b9cd715e340a6550495b7a3fd155cd838006fe3c2edbf325c24390ac28aa968cb7d7e90859ace3c31cd99f6344c5f0ed83152b7e380a539118 SHA512 e497a697a28fc431a4586bc6373c71fff102f65bec5a3b0e6d07fcd83b04124079a8b5f5e0ce9d714e4fdbf52df80ae83d676cfdfe4aca401dd0e7b3b26dc93a
EBUILD python-glanceclient-2.8.0.ebuild 2612 BLAKE2B 844e6ab91a070f9d20fd4418be7b63776eedc900c568ccf89f7c78f52f03fe6675e06249dc0eba5f56fcd70402d133192f77da1bc65ed1f71603852565b8f3b1 SHA512 ff395ab1c060e51278a7e5b6cb283827776a7a7d3e008d1fc0932412f05df0373f6d3f0bceec56e0d1e55d93d5256e59e6da6a15171b6f45bfc394a8a6f7abd0
EBUILD python-glanceclient-2.9.1.ebuild 2441 BLAKE2B 50a79c1fce26ab8cb144944fff87afd00f8b83f63748bf01cac0ab84dc425acd9148ba0e5577fdaaf48dc430d92a9852073a9935d045b12166397100e54cedc6 SHA512 3b785c8b08d165b61ce665f3e41655afc9025c5fa8f58a297b4f7b673be82b366ab5146bb158a7bd6e412240f60584c8c66500faf9d291ef0715d9bc1befdcac
MISC metadata.xml 632 BLAKE2B 69885578505253d6ec3d0245779a89ebe5c75ab8a8e9fecbf95c29d4aa17ba6864e69c1806a01cde0e92080a86ccbae146bdb2c003f50fd3dfd32b6d2186536f SHA512 d807a9aadecb131f92d6a476a8bc0b0293d46c6ac761a2d1ddb596ac219c6c8ac349402e3f56d150e78ad81c5d2838a33b3d35222a18f9a416f969f6d6208d8f
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.10.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.10.0.ebuild
new file mode 100644
index 000000000000..bffb4cc4e44e
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.10.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ordereddict-1.1[$(python_gen_usedep 'python2_7')]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}