summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-glanceclient
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index a0e48b997633..78f6dad723dd 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-3.5.0.tar.gz 198273 BLAKE2B 7861a2124a9474c4f6267f5b82e6d7fa9825d3cdc8411fbb05afabf69928dd230a881452de57cf54f9cd1a52157f806826036d85f6a93651980ce65e86afd520 SHA512 e5db1afeea7e3f653d7afac7961aeb3ec28df5dc40bba6b8b70795efcfc66928c2af45ecc0e4bbcc0d59a0157599e4ef3af090a8b0ccd0d727e8a94d4f8c866e
+DIST python-glanceclient-3.6.0.tar.gz 202581 BLAKE2B 20bf5ee863cc3d319cc7b670f4a218c9b84b49c392f7a7756636a93643ddf81781f808d6d966ca1982246b66b7963354c433239f554eb2aa0291bd1d57da2e79 SHA512 7bcf08386cfe6d4787dd8e6616907814a53fcc35bdac1818aef7ba094dcd37dfddddda43a1451d55f22d175f400f8680801d1a43508c5d85ce39f15164b71a5d
EBUILD python-glanceclient-3.5.0.ebuild 1327 BLAKE2B 9ccd77c947ef67f2f5283040de020fd90aac4cb0201e81b2e79999c6eb34f929c0cb15c2d64067edf5fda8a2570ff5032cda12ab7776b4c974049c6b71e68f9e SHA512 a859f94cbe72fabe854e73f2593c3dd1049e51f93b868f82492d1df8d39b4d1eab1f96074964e8fbea678e826a83bf17ebc1e30782c47a064336385b56b97157
+EBUILD python-glanceclient-3.6.0.ebuild 1364 BLAKE2B 3aca14cf800c49306b79ad29da6872945d7448c270724c297e1699bbee851e9914553d5d5988edbdc5e67f6d7eec5267534c05fadc4ca8fa82a3868b185ffb23 SHA512 1d0dba6aa08eb4296204371885bc9e77d366878a4a49b50c2bfb2a483c4406c166bd389891923828d8b399c7beb90a0ed0226a52fb5a8c422c1b561a5d7b47f8
MISC metadata.xml 556 BLAKE2B 1007f5d86b8a7a5feb6018997ad5126f31c10d619d480adaf28db855ae9745c1395632b1d0fb9c915106e7678b7148487c3a2de800e8bf19e1abe55b00df7ecd SHA512 43aa944c6c8a91dfe59aa8261718fe144c852f0e036cddbf4453cfcfde21816e619388de98713de965d03c63ae242ee4fc27be103263cd1d44a5985b3c905fd0
diff --git a/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild
new file mode 100644
index 000000000000..e4df4bd7c457
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-3.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}