summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/python-glanceclient
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.12.1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 593ef5579357..4af33077127c 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,5 +1,7 @@
DIST python-glanceclient-2.10.0.tar.gz 180299 BLAKE2B 0d97626361ad7fc2c688f5da6af6d49bf6e078f715560b4ac93725f8ea6df895e7eed0e44bf69399c973978af22ebaef3d371ae19026cff7fb2bd896c8be30d2 SHA512 9132493559d7a7b6de62e5ec1bdcd7a2dcf408c00bb0cfaccb6e11829975d468bfe68feabd71fdf8cc0d28a2c5c549945816aa14c9469314ffafd3d39b9c2da6
+DIST python-glanceclient-2.12.1.tar.gz 182868 BLAKE2B eec3751fc3ba9d820a92329bb5fe793a7173ab97fa4c17c2ec5c7ae87bf625dd4ef6bb3d0502c16847cdfc0a0c722b9043c4b11256563c593ced5a5b4f32f242 SHA512 080db737a3ac1e46cbad9c3da19b6383841a20210b2db7bcdf192db71ac530df13bf9dd9b5e8f5edda94170e26618a85afbcece5eb5147c5eb35fe8feb72bbb1
DIST python-glanceclient-2.8.0.tar.gz 177172 BLAKE2B 0772b7e2b788b63bb590c8354dbad2c4e0bbd731f790f36916aeb154a44474f979961195d307e45149bccd2a58e1df72c48aa0593d6972c606b393f1202ee440 SHA512 257eaf1d548a3a6277b9c80e8b23b9ae4231586307c43a064754c227f3e3c872451ec0469aca931638ea0f7c9920892878c677b144dc72bad215c38d375a63d3
EBUILD python-glanceclient-2.10.0.ebuild 2441 BLAKE2B 42a7436e9cc23de10ea276ee0c46ad4c8f86a767a5f8e406a57b444cfbf4e3019afdec95a4f154265adecac0b33bf6f142d15897a83e297fb853ab555ea6cb37 SHA512 b1cfb4b3ecb7f4baf5cc355a20e1417eb82e1f742f9d88ef908f816e53f34e8a88a5c75ddbdd8bd1116b9dd1cb7b45a2ea9bfa5e4e53f218f3cd8c3ef9559404
+EBUILD python-glanceclient-2.12.1.ebuild 2489 BLAKE2B 229a347ae7abe0a318ddf2699cc50f798d8a87c4128614d6bb49c78cb40c2a414da2936b19eecce24fda4a5348b315d1a80428a4202b39f395a19b2320801838 SHA512 2bd8c88f23bc3a06a39520f01c6e32ef7639ebb11c84e8f56d15d2f6f3232cb35ee93930664259799e74db97fd871c23919c12a22c0f2eeb0de566242fec0c0e
EBUILD python-glanceclient-2.8.0.ebuild 2612 BLAKE2B 844e6ab91a070f9d20fd4418be7b63776eedc900c568ccf89f7c78f52f03fe6675e06249dc0eba5f56fcd70402d133192f77da1bc65ed1f71603852565b8f3b1 SHA512 ff395ab1c060e51278a7e5b6cb283827776a7a7d3e008d1fc0932412f05df0373f6d3f0bceec56e0d1e55d93d5256e59e6da6a15171b6f45bfc394a8a6f7abd0
MISC metadata.xml 632 BLAKE2B 69885578505253d6ec3d0245779a89ebe5c75ab8a8e9fecbf95c29d4aa17ba6864e69c1806a01cde0e92080a86ccbae146bdb2c003f50fd3dfd32b6d2186536f SHA512 d807a9aadecb131f92d6a476a8bc0b0293d46c6ac761a2d1ddb596ac219c6c8ac349402e3f56d150e78ad81c5d2838a33b3d35222a18f9a416f969f6d6208d8f
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.12.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.12.1.ebuild
new file mode 100644
index 000000000000..f7e95c5df9e1
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.12.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ordereddict-1.1[$(python_gen_usedep 'python2_7')]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}