summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
commit02fbebe9426ee05ab39e9b5a56e3529e64160ef6 (patch)
tree4c2a5db6966711f46fbc73aece931b17625e27b7 /dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild
parentb052fbf151106a4f47cac7fdf0ffff983decb773 (diff)
gentoo auto-resync : 02:09:2022 - 10:16:01
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild
new file mode 100644
index 000000000000..5d8029e264f1
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+# Tests fail with dev-python/prettytable-3.4.0
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ <dev-python/prettytable-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}