summaryrefslogtreecommitdiff
path: root/dev-python/python-gflags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/python-gflags
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/python-gflags')
-rw-r--r--dev-python/python-gflags/Manifest1
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-gflags/Manifest b/dev-python/python-gflags/Manifest
index e67059b99ede..0c065bd8a16d 100644
--- a/dev-python/python-gflags/Manifest
+++ b/dev-python/python-gflags/Manifest
@@ -1,4 +1,5 @@
AUX python-gflags-3.1.1-script-install.patch 1178 BLAKE2B 26f5694548762a2d6b8e6787027862edba91e8baf39a7c8dfc573be61af48cebf7a280646c948c0b59fab48d3b46fd4049d8422f8d4e6d9a57afe6e363c63999 SHA512 7247303c33a845949b1db7104f3170497da980334cb02155501d194eb53eb61ae2231cd4ece06194ca64514271252f8f1fc7c7683cbff2bb8f96d6d4e88123d5
DIST python-gflags-3.1.2.tar.gz 52093 BLAKE2B 4275b43ecf2c58f76fee0b1ff4645eb3176a9ae3b68fdd4a059c2f6f659ca1d9b6e4fad152a2fa48f1eb22c467dbc006835c241c21f89c0ca92367e484f34c6f SHA512 7a3c08b6b212cdb9cb7feaa48e3875d1204a4b3a57182508a078331565f70509d00c315400fa0316dbf61ed4d6a6a04ca8c1a2303567d37650d8dfbb329e2f6c
EBUILD python-gflags-3.1.2-r1.ebuild 823 BLAKE2B 192e57534bcb46ba58bcae9beb33a528d5ab9c370cea5559aec2a86522977b671b12952db76bb6f23e1a3044daa1a812f2676c1264971df9809cd0de9510ae4b SHA512 e5339dcf70e7a9ae896babb6a7bd8f485ea79db4ed93634be5eb1b1921015022dfcc40d34db36c377e773427eb6d7e5d6b6c0d1600a42c72e05215274dab85fd
+EBUILD python-gflags-3.1.2-r2.ebuild 831 BLAKE2B 5dce3f3ab9024ccf8afe4ab0e54ed46468cb6a0e9924ba2ab04f96aedc998706db1d7ab62bdea1017c30f1522a12d2dd2f3b4245d4d4bfd5201bbe23c2adfdb8 SHA512 7015f73a0154d21c5b32b4b2aabd586a466c1cd325dc1612df3b39f99050f19f37a56d4692a9f47bc3dee07534c0bd9cbc5f84a4fa0f9f2c60bc11c6643cb826
MISC metadata.xml 401 BLAKE2B eae24da2b1e8099693b44fe2aea5f124cb8d4ec8a3e3b2caca54687325b8340f3f449b3c5d65aecb3d526c40d804c42d97d42b0afefeae8105fc33193835cd90 SHA512 dc651536c02078847ee2c24ed88d0fb4c24852224c3a1832b2420fac6ef15e9431917c238524030d28267cdefa65f491dc1496094b1dae1df32b604712d8c1f1
diff --git a/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild b/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..251a537291ce
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.1-script-install.patch )
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${EPYTHON}" -m gflags._helpers_test -v || die
+ "${EPYTHON}" -m gflags.flags_formatting_test -v || die
+ "${EPYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}