summaryrefslogtreecommitdiff
path: root/dev-python/python-gflags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/python-gflags
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/python-gflags')
-rw-r--r--dev-python/python-gflags/Manifest2
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild21
2 files changed, 8 insertions, 15 deletions
diff --git a/dev-python/python-gflags/Manifest b/dev-python/python-gflags/Manifest
index c2394a3526bf..37df15f48cbf 100644
--- a/dev-python/python-gflags/Manifest
+++ b/dev-python/python-gflags/Manifest
@@ -1,4 +1,4 @@
AUX python-gflags-3.1.1-script-install.patch 1178 BLAKE2B 26f5694548762a2d6b8e6787027862edba91e8baf39a7c8dfc573be61af48cebf7a280646c948c0b59fab48d3b46fd4049d8422f8d4e6d9a57afe6e363c63999 SHA512 7247303c33a845949b1db7104f3170497da980334cb02155501d194eb53eb61ae2231cd4ece06194ca64514271252f8f1fc7c7683cbff2bb8f96d6d4e88123d5
DIST python-gflags-3.1.2.tar.gz 52093 BLAKE2B 4275b43ecf2c58f76fee0b1ff4645eb3176a9ae3b68fdd4a059c2f6f659ca1d9b6e4fad152a2fa48f1eb22c467dbc006835c241c21f89c0ca92367e484f34c6f SHA512 7a3c08b6b212cdb9cb7feaa48e3875d1204a4b3a57182508a078331565f70509d00c315400fa0316dbf61ed4d6a6a04ca8c1a2303567d37650d8dfbb329e2f6c
-EBUILD python-gflags-3.1.2-r1.ebuild 845 BLAKE2B 65a149ce9148fd6b4e6782d1e23befbe0c1b48cd4f2c7f2382678819c195beb2abf9bc23fb897b194b833a56e07f7c51806a3e8ca3556c1da22b3ebad4f9fc71 SHA512 43cd5166e146ef7d890f806ec5d49c46a469d0e22cc05a27f89c600ca6ab68e66606bbab7ce875517987e856187ae5fde2784c7c861155d991019acbfb4c6c00
+EBUILD python-gflags-3.1.2-r1.ebuild 822 BLAKE2B 5e039b367693a82bf5fe191dbb35adbf125a58637934d84507e91563c0601fdfc9bd060562b270cea1cd85a73298702d99c9951f4420ae0da4bc47823ec8ca6c SHA512 2ee39eabc9b12ab0725e486bfcf33e142d773767ad0ddab0e97d4bee51aa932dca82fee4ac7237a23c958fe39d40f09ca956c2015cfc54141a901161f12facb2
MISC metadata.xml 400 BLAKE2B d273614233adf08aa64eb4339fe8c55899901d86405dba1be0a80e20b3efcb9856a399fa76883bc96e4dbe66b52e223b990d638fd4523c0e1e974606ca2902ed SHA512 35469aeba6e9273b765361e6543c6019bacb3a1a42c5aa232d62d82284bc59f5e04c392f3934b3097fba63d9101530046f1f93119561ea0d426259374c5d6fb9
diff --git a/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild b/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
index 22c0041b2e4f..90fe031744e0 100644
--- a/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
+++ b/dev-python/python-gflags/python-gflags-3.1.2-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8} )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Google's Python argument parsing library"
@@ -16,19 +15,13 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-script-install.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-3.1.1-script-install.patch )
python_test() {
# note: each test needs to be run separately, otherwise they fail
- "${PYTHON}" -m gflags._helpers_test -v || die
- "${PYTHON}" -m gflags.flags_formatting_test -v || die
- "${PYTHON}" -m gflags.flags_unicode_literals_test -v || die
+ "${EPYTHON}" -m gflags._helpers_test -v || die
+ "${EPYTHON}" -m gflags.flags_formatting_test -v || die
+ "${EPYTHON}" -m gflags.flags_unicode_literals_test -v || die
}