summaryrefslogtreecommitdiff
path: root/dev-python/python-gflags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /dev-python/python-gflags
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'dev-python/python-gflags')
-rw-r--r--dev-python/python-gflags/Manifest2
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-gflags/Manifest b/dev-python/python-gflags/Manifest
index 551f5b54e557..3cfffea01b38 100644
--- a/dev-python/python-gflags/Manifest
+++ b/dev-python/python-gflags/Manifest
@@ -1,4 +1,6 @@
AUX python-gflags-3.1.1-script-install.patch 1178 BLAKE2B 26f5694548762a2d6b8e6787027862edba91e8baf39a7c8dfc573be61af48cebf7a280646c948c0b59fab48d3b46fd4049d8422f8d4e6d9a57afe6e363c63999 SHA512 7247303c33a845949b1db7104f3170497da980334cb02155501d194eb53eb61ae2231cd4ece06194ca64514271252f8f1fc7c7683cbff2bb8f96d6d4e88123d5
DIST python-gflags-3.1.1.tar.gz 52633 BLAKE2B 78966a7ffd924dcb16b4c6459d10cb06b9494150887433fec1e32e1b454f151386d4024f3ba1d307f756781128224c8106539480d9291dcc2ed82e85c8eef36f SHA512 28009cdc09b94b416af5237d3897d6ab516cc3b6a3eed18a31adb8c199f31a8c7d07b1d69794cb37de84b50eefbde1de57f9f0afaeac0a4747b352f4024ef12c
+DIST python-gflags-3.1.2.tar.gz 52093 BLAKE2B 4275b43ecf2c58f76fee0b1ff4645eb3176a9ae3b68fdd4a059c2f6f659ca1d9b6e4fad152a2fa48f1eb22c467dbc006835c241c21f89c0ca92367e484f34c6f SHA512 7a3c08b6b212cdb9cb7feaa48e3875d1204a4b3a57182508a078331565f70509d00c315400fa0316dbf61ed4d6a6a04ca8c1a2303567d37650d8dfbb329e2f6c
EBUILD python-gflags-3.1.1.ebuild 856 BLAKE2B c551cc061fb0cdaef70429ffa9c94f69c21351b2b33392355aab2fac76946df4a9024fcd5078dad10405f98ca2df89d95386ca44b9046180dd91c8316284ebd6 SHA512 380ec4ea584144f6e7e111283a1ecb08eff940ee13d27dded5ba798bccd8f2bf8c6906c229bddffb764b252d38ab9fa5855b64b8bec658ccdc92d02f34c2ef6a
+EBUILD python-gflags-3.1.2.ebuild 877 BLAKE2B 502d25482cdbd6453feb82dec98a9e5c320b0c74cb6341f04eba9bc5fbbf6dbc7571d4dc46b4abc382f6195f52bc9fc97a9586a579f76b8b463d9eb884d502af SHA512 306b608bb8ebe028a83bb320d30d62d39f10a2ebe7906927e1b6b739f3900aa69aa74044629d739eaa4ebae3c6ed7c0eb4e7dab07709fdf104c10f6ea9a35b31
MISC metadata.xml 376 BLAKE2B f93ffa8d2487172461a680a02dad64b46c2edb87ed47ffd8455c30c82278587daa1d2baa42fd0e77f0cbdcff7936e9b99a1f8a8bd496f55eb27975d708656069 SHA512 acea21fc3fc83a3ab1a24f47ed7250c1ffc15ac4507c4c1472716a55b42fa0740b0a5d2eb20cc3dbfeacc575eed67d59b59e722e96dcbfc87672ddf9b9787c26
diff --git a/dev-python/python-gflags/python-gflags-3.1.2.ebuild b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
new file mode 100644
index 000000000000..fbe985dcaf55
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-script-install.patch
+)
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${PYTHON}" -m gflags._helpers_test -v || die
+ "${PYTHON}" -m gflags.flags_formatting_test -v || die
+ "${PYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}