summaryrefslogtreecommitdiff
path: root/dev-python/python-gammu/python-gammu-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-gammu/python-gammu-2.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-gammu/python-gammu-2.5.ebuild')
-rw-r--r--dev-python/python-gammu/python-gammu-2.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-gammu/python-gammu-2.5.ebuild b/dev-python/python-gammu/python-gammu-2.5.ebuild
new file mode 100644
index 000000000000..9f26acf10bbf
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=app-mobilephone/gammu-1.34.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}