summaryrefslogtreecommitdiff
path: root/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild')
-rw-r--r--dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild b/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
deleted file mode 100644
index d8396eb3e0df..000000000000
--- a/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Flexible Collision Library"
-HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- ~sci-libs/fcl-0.5.0
- sci-libs/octomap
-"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-compiling-on-lld.patch )
-
-distutils_enable_tests unittest
-
-python_test() {
- "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
-}