summaryrefslogtreecommitdiff
path: root/dev-python/python-fastcgi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-fastcgi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-fastcgi')
-rw-r--r--dev-python/python-fastcgi/Manifest4
-rw-r--r--dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch15
-rw-r--r--dev-python/python-fastcgi/metadata.xml11
-rw-r--r--dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild33
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/python-fastcgi/Manifest b/dev-python/python-fastcgi/Manifest
new file mode 100644
index 000000000000..f203a8c57ab2
--- /dev/null
+++ b/dev-python/python-fastcgi/Manifest
@@ -0,0 +1,4 @@
+AUX python-fastcgi-1.1-setup.patch 452 BLAKE2B 6f2a965ee3884e5d23b3f2d65035943412d739a6cb8b13825c1125582cd931e97f68d2dce5fe866798245f13a9b7627a372bcf4433d4b769e8f17d07bbe7001b SHA512 715bcc32ac2d9151765e5163860b69fd3bb0fa4d2efb715dc7dcac1d12a10b436b2eb4ee0ce64ce95696c5b44d5a9702a7b60ae650fdf77fd914173ab48cc18e
+DIST python-fastcgi-1.1.tar.gz 11180 BLAKE2B 42884126798b67bdbe969a18016faaaa2b3a4f10be1bae56824d79e42a7c63585f42c0fab699c73697401c151fbedc470037cd0e8c98b839e6efc58e29065531 SHA512 316c5b07342d27bbad90704909d7a010997801527a9069d23e39975bd3a0e82ab7407bb5e5aa9bdf240039d4c2fec37887540c569d496ca3a328f3323390da89
+EBUILD python-fastcgi-1.1-r1.ebuild 750 BLAKE2B bcb682868eefe0f6c3646edfec062651b373291a0e5f58a59012ce66c3a609350a62d62c8005aaad714a9dd6b4027927a12eaab29a4ef46b1caeb5630738b365 SHA512 ffb79203acc5e481fe50c12c1f79350a678224e77fb04e28333cfcefd963816c2dffe173cafae1e6cb57ce1c58e238fee97ad3f80d990706fe7f9c8603b9c460
+MISC metadata.xml 317 BLAKE2B b409c80dfcef216e1c898e0ac2699cabb625dcb862275ef87b436d8648022b474f0c39c86d08d5ce8aecde4e2913e51691265691839d58ca367405ce341090d3 SHA512 2a826c8c090029b312458c77217502813bb35f5653ae176d60415a38c348d2774cb0a4ae5045ed7b14da530ce88a02854623fcfe2a8d7d7f9b77804ec9f7c117
diff --git a/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
new file mode 100644
index 000000000000..6ce721a5e004
--- /dev/null
+++ b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
@@ -0,0 +1,15 @@
+--- setup.py
++++ setup.py
+@@ -4,11 +4,7 @@
+ from setuptools import setup, Extension
+
+
+-c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"],
+- include_dirs=["/usr/local/include"],
+- library_dirs=["/usr/local/lib"],
+- #extra_link_args=["-s"],
+- )
++c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"])
+
+ setup(name="python-fastcgi",
+ version="1.1",
diff --git a/dev-python/python-fastcgi/metadata.xml b/dev-python/python-fastcgi/metadata.xml
new file mode 100644
index 000000000000..33b2fb0e7bfc
--- /dev/null
+++ b/dev-python/python-fastcgi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-fastcgi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
new file mode 100644
index 000000000000..eec37629089b
--- /dev/null
+++ b/dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK"
+HOMEPAGE="https://pypi.org/project/python-fastcgi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ append-cflags -fno-strict-aliasing
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}