summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /dev-python/python-engineio
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest2
-rw-r--r--dev-python/python-engineio/python-engineio-2.2.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index e7bf7e59f1c4..44af928079c1 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,3 +1,5 @@
DIST python-engineio-1.7.0.tar.gz 22804 BLAKE2B bc807943cc24eddbc9cb25ceb55223ecf610ed37b281e5b0a59935705dc2d2c34ad5795e0bd96f1256cf91365756e43ed9c94b1082334d6f6c34f6b6e9472710 SHA512 1d184ccb9d1328d9f4e2fa22006f1d21bd17200bc893ee2588b4342da24775f98648e0e993893eb56a9159f95a114f128dfdacef9fa8ea296c7ace6c7741aea0
+DIST python-engineio-2.2.0.tar.gz 22137 BLAKE2B 5e864a4cb2bc5048f459f98e24894bf263caedaf58ce3225dbb216fc5f4722efbaf7f346c39869daf485debff1479db254add66f6f256066ed26a11a8be196b3 SHA512 8e601c583bea21b37fc673bf92e3b40d6f3ded7068e7b103111b60d6677195e67338398934a270dacc8621b040e52d32eb9652e15607c7be69b6c50a8d19eaf2
EBUILD python-engineio-1.7.0.ebuild 761 BLAKE2B cd8d17058b3a44ffd4e7a3998f595f99b0887fd13fbe0cb25df7153d2af68ad53f1550cc41c0f7c489ba7ed06cc4226d569e0aa901601a25e85e1adba231482b SHA512 0311a14f2683ef42702ee446d7219f47c8359e9090374ecb58384be1ef97b58f0f592722b818e5decca221bb04f4a0cf9a21496e5b5817b8c2f593e61f494004
+EBUILD python-engineio-2.2.0.ebuild 761 BLAKE2B cd8d17058b3a44ffd4e7a3998f595f99b0887fd13fbe0cb25df7153d2af68ad53f1550cc41c0f7c489ba7ed06cc4226d569e0aa901601a25e85e1adba231482b SHA512 0311a14f2683ef42702ee446d7219f47c8359e9090374ecb58384be1ef97b58f0f592722b818e5decca221bb04f4a0cf9a21496e5b5817b8c2f593e61f494004
MISC metadata.xml 466 BLAKE2B 6ed10a68ef43c4462dcc0fd1ff545828cb6a38d63323da41ea1403d62c7465c08b2668319a0924b31d07719ccc0bd8587461d63362acddd9e329f9800b26bda7 SHA512 4b945547b692e81069a2ae0d70af112945aa2200b935efbddbbcfff4fea60268a9933dcf7ba2936e6c7a6655ef805f93252f157e63771e068a7ac6fb82c4de1a
diff --git a/dev-python/python-engineio/python-engineio-2.2.0.ebuild b/dev-python/python-engineio/python-engineio-2.2.0.ebuild
new file mode 100644
index 000000000000..780c7de65f76
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://python-engineio.readthedocs.org/ https://github.com/miguelgrinberg/python-engineio/ https://pypi.org/project/python-engineio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}