summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-31 06:31:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-31 06:31:03 +0000
commit2e36bcecf24a3f583ae8f27b71ba13b3cfd39778 (patch)
treef2362fa4c0f61f631c2b7a484fb90b8283618656 /dev-python/python-engineio
parent7d7cc3f0fa58454952dec67b110b41d503bca422 (diff)
gentoo auto-resync : 31:12:2024 - 06:31:02
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest2
-rw-r--r--dev-python/python-engineio/python-engineio-4.11.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index d6d6904fb485..bcf3e5aea25d 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,5 +1,7 @@
DIST python-engineio-4.10.1.gh.tar.gz 317153 BLAKE2B 3e75591bc79bc705dd844283485e7087a97a5493a1a8db0095bbbb2935de60deba394fae2f0136167692170ab5dc21713a7683819f49528f8912c58d9d9b51ca SHA512 6fa6828803143579564b89c6ba121dd3430d884e09eff2d2a0f9018056b2c88a0b7ecaa792ff5d1d12c86fabaf48d171af266ca9a0e9aee9cee80dc02af06210
DIST python-engineio-4.11.1.gh.tar.gz 319420 BLAKE2B 8c6f56da262f824f5880fe7a5b955bedd39973de922ad9cf274f2c16d2546b7aaa5d55cc4c35a4a8b5dfa6c0611447cf1ea2f3137883023e41cf4cf59962977d SHA512 e87f62229b0d45da015d4837bbe13a2310e895f27ec24daad21a1d4d077bc5ca73b20672fa20d1c0141ea6cbcd9e842ccd495bac79fc3f33e1e7bd068aeb232c
+DIST python-engineio-4.11.2.gh.tar.gz 319497 BLAKE2B d3f97f34c6e8043b0079c1555a8b4acb12f068883a1d117b19e0875d445239cc3c24e884f9b63c82268e9a8c67f3bbac193acc417cdd441e6f9d07cc79b97ccf SHA512 05f7fad64c3ddb136bb9fe4762bc5125d1e72813bd8f28d0c567c016ab3db9ff3b99719eafa106b997ce90da71be5aafb2bd34460d5097a9f68cf4dc7db34ba7
EBUILD python-engineio-4.10.1.ebuild 1498 BLAKE2B e2ef9f9cbe9728ac6332bce49e8c7bb69e6e25b7ec90dc45b5ed30adba6916441ef9954510439cd0b93b89bdfe2672f6126ce99dc81f45346af7a4d0a7554a67 SHA512 95b5631ab26356a54b12b11bfe6566004efe3871e9cadbda9e33c44bf477a355fd3a3587011bc223b8930ff0a0d1711c612c95669b4142d22edb1e1f8838a7aa
EBUILD python-engineio-4.11.1.ebuild 1555 BLAKE2B 1f143ce219087c96cd0fd3f3c6e09db2b336052492ff552f959707e150dbe9ba1239868e9adad049f1bb220eeaf29e71cc9e08705ae06228e170a9fe26a970e0 SHA512 21e3192c31bcd828703339a7bb12028c62b3d5040fb9214c270fdba2249dc73c37de471ed81716b1afb4342017432f7107f48868443a0ab4a4a1529ecd4923f6
+EBUILD python-engineio-4.11.2.ebuild 1555 BLAKE2B 1f143ce219087c96cd0fd3f3c6e09db2b336052492ff552f959707e150dbe9ba1239868e9adad049f1bb220eeaf29e71cc9e08705ae06228e170a9fe26a970e0 SHA512 21e3192c31bcd828703339a7bb12028c62b3d5040fb9214c270fdba2249dc73c37de471ed81716b1afb4342017432f7107f48868443a0ab4a4a1529ecd4923f6
MISC metadata.xml 518 BLAKE2B 7325d24cc26b1a3b4e2dec04159cdd4ebcceaf0384fccbee11205f9c000b1e9f84f97c742a6181dbad419e2527c6f874bc3f89760daa6b6dd2feb9b1f874b515 SHA512 40fe9ac96224019d28206f75ae6249c75dbcb759918c03826af4f8a394586bd5df445ef475cd009e8af93ea5c7424abebbbfd65ac2e2eb7bdd9e8a29f2dcb34f
diff --git a/dev-python/python-engineio/python-engineio-4.11.2.ebuild b/dev-python/python-engineio/python-engineio-4.11.2.ebuild
new file mode 100644
index 000000000000..f32bad5443c1
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.11.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/simple-websocket-0.10.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}