summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio/python-engineio-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-engineio/python-engineio-1.7.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-engineio/python-engineio-1.7.0.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-1.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-1.7.0.ebuild b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
new file mode 100644
index 000000000000..780c7de65f76
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-1.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://python-engineio.readthedocs.org/ https://github.com/miguelgrinberg/python-engineio/ https://pypi.org/project/python-engineio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}