summaryrefslogtreecommitdiff
path: root/dev-python/python-efl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/python-efl
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest2
-rw-r--r--dev-python/python-efl/python-efl-1.21.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index 4e7839f745b6..7ccc4abd76c6 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,5 +1,7 @@
DIST python-efl-1.18.0.tar.xz 8927932 BLAKE2B c1b41e1316c78fc42cf21541aba386dce799f1ec26549dda8c547de4cf47870a100070bb442d21116ce956808bcf948eba96601343512ba61fb1fc472e2574be SHA512 c1fc8d4129c2ac61b367ad373ad676a60cf0aed4c9150104d7e81bf464c44a3a5ae555d2298bbf1bdf6a3d6ba3b7d934af390e36755a1516972db2675d920c2b
DIST python-efl-1.20.0.tar.xz 8984492 BLAKE2B 526c530d7b8dad59d01cefcbb6cad2710cb46c3b62eb0b2746c3552c8c1ef42cc4691072fbbce16a8a3b6ea9d6b5651a3645ca739e569a0f4db3dd9988ddf2fa SHA512 93d8d6c990350074e203bf3632d92b5253f34f318b30357b05ab5ab73a9f6656d127ff0c1831af1bf7c736822b483c12754085e52103eb0e41362cc28db5651f
+DIST python-efl-1.21.0.tar.xz 9544352 BLAKE2B b49fc0e0d795a0334f647f414673fdaf3b086eda35f9e2d0e9e6a03d2cde572e6076eeb62c4f977b770a72e8f14d4ae536f46d0510b8753088d80e2dfc98e43f SHA512 23a8487b660e9885a1d43a4835c560edd8d27eeb9aa44f9e1878ac1d1acf9833fc62c14036fe0fe5e0bd1144cb993b0b67bcf42c78db8505ca1b8aad0715350f
EBUILD python-efl-1.18.0-r1.ebuild 1481 BLAKE2B 529a6def5b6c9f1cdf49683c5307b90ea3281cbbad85a71dc69745fd6d853f9698d06805ae87a64d810170b5612a8fc04cfcb382dda21aa8df135d5379d39ec4 SHA512 3a2b5e0dd91ebaf1f8992134f8f80f6f67b02e19db98e0263c6b91249ef41df35f47c77e37afed37522649b98d30d25b58037d4ec9c923ee60c45679dc8bf7d7
EBUILD python-efl-1.20.0-r1.ebuild 1767 BLAKE2B 2f770e0c9f80a024c94cc508c2b19a55e131392b232b5048d936a73cf2ff1c02f61635f5fd4a0472191b01088d871fc4a4452b3ead10c8cb0fdc89a0f92e81dc SHA512 d1ad00014745970625ca74450559f25db4ae025507527e2369669cea1d7363f10537e4fbaaac56fc8d6872acf7f5273d0652c480807f22e3494e2eac1cac90f6
+EBUILD python-efl-1.21.0.ebuild 1746 BLAKE2B da2098b40d24ac5e08971e4686e019201bdc4810eb27083a9dc871f72ce5aeaf71ba87d4d98ca0491773b499679aa7720dddde95afa730c7f570f797741017f3 SHA512 2074ea00f5affab6409d1ae25e202006a71f953e3f4570253c01048443427bae21a18ddc830499c56298a73388b00afe9580163e8028c6109c0d348d602e4470
MISC metadata.xml 678 BLAKE2B f63779daf5a74d59f8dc65002ae8ec55585ae58c2bb02d951fd1ced15fd68fbb4ffa18239b8ef48347ff18e5cf033faa4a141f8e4fd8898bed6d74a9fd18d065 SHA512 a618f3bf8c4eed0e00b889f2c1bc85d46dc5ef1118f393f4cf10857d0b1a75720c6a719ed97117e40420600059e34eff0be3771fa684b89d437459f012fb7c5c
diff --git a/dev-python/python-efl/python-efl-1.21.0.ebuild b/dev-python/python-efl/python-efl-1.21.0.ebuild
new file mode 100644
index 000000000000..923b11076c67
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.21.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4..7} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ =dev-libs/efl-1.21*
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ default
+
+ # Tries to download a file under /tmp
+ rm tests/ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm tests/ecore/test_10_file_monitor.py || die
+
+ # Needs an active internet connetion
+ rm tests/ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
+
+ # Make tests verbose
+ sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
+}
+
+python_compile_all() {
+ if use doc ; then
+ # Point sphinx to right location with built sources
+ sed -i 's|"../build/"+d|"'"${BUILD_DIR}"'/lib"|g' doc/conf.py || die
+
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd tests/ || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( build/doc/html/. )
+ fi
+
+ distutils-r1_python_install_all
+}