summaryrefslogtreecommitdiff
path: root/dev-python/python-editor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-python/python-editor
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-python/python-editor')
-rw-r--r--dev-python/python-editor/Manifest2
-rw-r--r--dev-python/python-editor/python-editor-1.0.4.ebuild19
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-editor/Manifest b/dev-python/python-editor/Manifest
index 47ec2833e941..dba38c89876f 100644
--- a/dev-python/python-editor/Manifest
+++ b/dev-python/python-editor/Manifest
@@ -1,3 +1,5 @@
DIST python-editor-1.0.3.tar.gz 6975 BLAKE2B 23a4b0990f8715eb0b0ce538f1fbf47d61cf7209588c8be31ae3fb047c706eaf2628c04b29dff517a221676566241f066053680749ab864d067334f875796eba SHA512 258d1ea17ea1c09d8ef52d3b624cc17710559f4a8db3c64696f72aecfcc0830d3509dcdcc9d1ac272155b2aaab432edb7142b0a37f2c3263a2505bff940a3cab
+DIST python-editor-1.0.4.tar.gz 7132 BLAKE2B c955a2e3d2f607133781ef17146b20c13a409def6397e9698a8bc19c5a9f40af002a0f772455fb96e60088a732013ea6c471c198be0ac4c6c881724e762844c2 SHA512 c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6
EBUILD python-editor-1.0.3.ebuild 506 BLAKE2B c8d352b89f78b138d8da6929af94250e7a40350c0416b592eefeed3cf76bd21aae0bc9c3e01a525a37fbd568cf1f710c2f8cca27d87f6b80e7094b096a76c661 SHA512 77d555dc2c676c343deb92ec40038371de3135ec8387467659a9c6f0510b50b6c1917a6b40e06e218ac87228867fa7fdc0e6b9f0e1dd2bb1867f8f42c220830d
+EBUILD python-editor-1.0.4.ebuild 514 BLAKE2B 7d8083916c61ac037a61aa6eddbd815b221e35390489b2d922cbc4a55620924faa977fe130913c0ab586dd76d15f1c7d5543182128d907ddd9272b4d02c39786 SHA512 81edaa78798cb124c2dcb6dd8e3f5d05b19a9ac6b66595126b6b64012c5e5e97100701348db337ada4c66a2027a3e7d75a24496b7d014b70d636211628aa77d6
MISC metadata.xml 454 BLAKE2B a005031053af09882cc6f9e0a928d371d118cb44207567094e570b65a7cbc69c210ae2cdf6487473ab7d12793126953ef9fdf1d2954d9c31b58a2e783b563378 SHA512 2a75117477ebfe097dc4791d65581ccfd010406eeb3d5145c237edcee0b3af409ccee45abd83b18798ace1196206343a94032058f53e20a708c30ddcebe6b432
diff --git a/dev-python/python-editor/python-editor-1.0.4.ebuild b/dev-python/python-editor/python-editor-1.0.4.ebuild
new file mode 100644
index 000000000000..63553b089a2a
--- /dev/null
+++ b/dev-python/python-editor/python-editor-1.0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result."
+HOMEPAGE="https://github.com/fmoo/python-editor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"