summaryrefslogtreecommitdiff
path: root/dev-python/python-ebtables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-ebtables
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-ebtables')
-rw-r--r--dev-python/python-ebtables/Manifest3
-rw-r--r--dev-python/python-ebtables/metadata.xml15
-rw-r--r--dev-python/python-ebtables/python-ebtables-0.2.0.ebuild18
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-ebtables/Manifest b/dev-python/python-ebtables/Manifest
new file mode 100644
index 000000000000..f92f566099e4
--- /dev/null
+++ b/dev-python/python-ebtables/Manifest
@@ -0,0 +1,3 @@
+DIST python-ebtables-0.2.0.tar.gz 20290 BLAKE2B adf76b13d0f008ef422789e93e61748a07b348cc8575ed3ce2d73d3f21a6f20fce654e33f6cdb9283708aa80cbd2aa6de44dff5726a032ee198a9e5a7b70b29c SHA512 7051672d205b8318dcf7d08b50c8e0f66d9bb6532794d9292a890c5f75a88845f9e0cd9abf41450bf2a0516623c494eb40330021dc99320e5e0ffa56c75b100a
+EBUILD python-ebtables-0.2.0.ebuild 521 BLAKE2B 697f986e97f9bfb1be3f26ef38fb16c61b2a9afd8c87c18610fdaf964e432a1bcf5cc87d51108599df841be094828be6f305aa78c947e46a03d50ea23225a70c SHA512 0d4b3eb76b68445b295144410043e5dc550208158b3d16c08718eca7d7dfc5564958b449334fc43eabe69d1a41b15b273517db73600d44f55e9c0fabaa9e8f94
+MISC metadata.xml 508 BLAKE2B 08df10ff65a77f2168fead03d57f4d7352b5e7a790d744dcef389abbde88a2cc80f34aa6a156c7f679f95afc48d40f0a125ea30345f7a95e18a37ca4997069fb SHA512 ff808d70776d0dca06f0fc88f0e4f5fd873a85bd9e37d9cb86c88e1d72e24496bb273be2fe3735589884c53621425f1e7b17af2d11d69b96e559e8235141deb8
diff --git a/dev-python/python-ebtables/metadata.xml b/dev-python/python-ebtables/metadata.xml
new file mode 100644
index 000000000000..25d80baf6f13
--- /dev/null
+++ b/dev-python/python-ebtables/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ebtables is used for Ethernet bridge frame table administration on Linux.
+ Python-ebtables is a simple Python binding for Ebtables.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ldx/python-ebtables</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
new file mode 100644
index 000000000000..d8bec59d8cf3
--- /dev/null
+++ b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ebtables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="https://github.com/ldx/${PN}/archive/v0.2.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/ebtables[-static]
+ dev-python/cffi[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"