summaryrefslogtreecommitdiff
path: root/dev-python/python-dotenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/python-dotenv
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/Manifest2
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.14.0.ebuild7
2 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 01d5b43a59e6..b0d868a7923f 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,3 +1,3 @@
DIST python-dotenv-0.14.0.tar.gz 29029 BLAKE2B 33db159192faf9b74439b5e98e2b9a090a68001ac19eafd2925071ac7fc1872f7ee585b575dd96615c2ef934041dbfacca7948b7a8a69419243f9823f3bf6b42 SHA512 e8f6d575cd76cb231d14d98befe8a75017c927e0de39fbffc0ecb852b2aab1ada964cf37ed51c50968a4e8a96822a794c960a058a6deb6a2f0a8f8061d0560df
-EBUILD python-dotenv-0.14.0.ebuild 651 BLAKE2B c0e487604fa7003386c407b5aab532be099d0f3b66903827af98076ddc3fa790e199a235f61076a3068a9b2ca2a1215f553e7446516a787d859def9eabcf7826 SHA512 91298aaf03002fc0bb3c1f20c836c326954ca6f76fe24cf1c09e7ad9d2e24d5286ea76ade9611c7af71177a3122341efea8bf34c507fc2fbb5fef45614aa6cd4
+EBUILD python-dotenv-0.14.0.ebuild 844 BLAKE2B 04ffcf0f214faabdcf842d2294a757be9ae5db4f2b70ff05b73761750d25934da350cae01f5fb00b42049e9d8c9e2bab149a1b30ae17591873ec5e046789af14 SHA512 3ef07ae1fc7a2554a14d39db75f3906a9002ede7e41283e5c4599fd29e30b03f1017b7994c5a0f3a5b80703d12b5cef901a3e0d233c325a0e8fd5c87379b823a
MISC metadata.xml 365 BLAKE2B be359f891f6469f9d650dd2d0ec29e0641b3313f8dd5132462a3385d557a6cc72aab5fbf59f416c98239973630f8fa9c6e7d926b6cde078bb6535de322c033b5 SHA512 7eb826c13ed20a90b7317fad1a4647a8b52baad287c0286c3b1005c7d0ffbc148d376c8e7c4e2cb55a9af66aba6169f9a680e0f4eb8e8ad3fb7e55fce01b4b8f
diff --git a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
index f73be0464463..facf646f4b77 100644
--- a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
@@ -27,3 +27,10 @@ DEPEND="test? (
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest
+
+python_test() {
+ # Tests call the "dotenv" command which needs to be in PATH
+ # https://bugs.gentoo.org/743784
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}