summaryrefslogtreecommitdiff
path: root/dev-python/python-dotenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /dev-python/python-dotenv
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/Manifest2
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.18.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 3f2f1a4f746b..d97664d3ef1f 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,3 +1,5 @@
DIST python-dotenv-0.17.1.tar.gz 31608 BLAKE2B fdddfa1c39282ceec03fc1569d9a7d038e91a046a1248dd27af011dc60361f06f5324504d623a6109d783bb3b5ccac7cae758d918b17f5b0c65a1085bda627ea SHA512 42cdca1356ac2ad80884a5bf3ed419d1202d6a54746f7a21dc9c1bc7579383ac5c72e8b708bc33dfea3904228125fe7b3b2190bfe53e8b4767f5223d59050417
+DIST python-dotenv-0.18.0.tar.gz 32242 BLAKE2B 6cbef7ea7278a3114b3eaea2ede0c68e2c6dcc3868f655dbcad9596ea6e1ec0b9f5d183a73fda32e53d348ae23c11ca3f9d2e8eadd974eea4dd13903b9f9c845 SHA512 4b120ee45602ce703ee360fb5af07a8854bcb1ecd9084057e00324b152cf230fa6f065b374b6eebbfb7069b32762624ea61dd5d2fa6ac62cb7e3a2bb6ddfc1ed
EBUILD python-dotenv-0.17.1.ebuild 658 BLAKE2B 351ba0bda692ac281e924ed3a5c66e302b78a611b7a381c6dd7fc09d955ce5c386a8fa56bc4394430f69bf852abe47d7a8508067434246e9fb07311547400686 SHA512 261bb061544b4de0a3374e86ac272176f010d960ebf8661b990b3104173527fb0ec0fc69439abba10380c6bc2e4138e0ccdf98027e588bb1d076668a60a9344c
+EBUILD python-dotenv-0.18.0.ebuild 626 BLAKE2B ffa78d2f5bb37c74df4cf620fe47fe8ca7658cc748e50de88d23820aadaf63055946f5bd26e88dbc11145e738f8a22a66fbd9313c70c6a7d8039a5cec7c0d4eb SHA512 8d5d3c31b77a3f457e4526ab176d4fc84b78387c000513623d3a6622ecc4884addb986c79f6ead9767d836045c9f17c287f7a898f2c985f9197e34e88d68eddd
MISC metadata.xml 465 BLAKE2B 9b67c317b80cf8956d86e3482f9bd4b8824013c758e13c53865c4c8b428127a39188b23776176e038b4e58f8eb4e28b6ff7030df75a300bb647f969ef979a551 SHA512 f4bbf11566f50c90aeb7684755651f9112d3ce12dbfc425aa209eeff7c5a2636688a9236bd5227961cc334c07c82f49da0f4f27c3189bb7a0a8f76b517e9036f
diff --git a/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
new file mode 100644
index 000000000000..3fd9aa665e52
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.18.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests --install pytest