summaryrefslogtreecommitdiff
path: root/dev-python/python-dotenv/python-dotenv-0.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /dev-python/python-dotenv/python-dotenv-0.19.0.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'dev-python/python-dotenv/python-dotenv-0.19.0.ebuild')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.19.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.19.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.19.0.ebuild
new file mode 100644
index 000000000000..8c07ebae93cf
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.19.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.18.0-second-entrypoint.patch # bug 798648
+)
+
+distutils_enable_tests --install pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ # Avoid collision with dev-ruby/dotenv (bug #798648)
+ rm "${D}"/usr/bin/dotenv || die
+}