summaryrefslogtreecommitdiff
path: root/dev-python/python-docs/python-docs-3.8.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-12 07:39:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-12 07:39:50 +0100
commit9f3ff9d79a788d420003387392ec40fd0548efae (patch)
tree9dde8e6738d63f629a7879a0fd5949b1e7916b40 /dev-python/python-docs/python-docs-3.8.15.ebuild
parentc07955fffc8c82b9d37211c3f7f38455d7ef0599 (diff)
gentoo auto-resync : 12:10:2022 - 07:39:50
Diffstat (limited to 'dev-python/python-docs/python-docs-3.8.15.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.8.15.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.8.15.ebuild b/dev-python/python-docs/python-docs-3.8.15.ebuild
new file mode 100644
index 000000000000..db7df46c6ffb
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}