summaryrefslogtreecommitdiff
path: root/dev-python/python-distutils-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/python-distutils-extra
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest2
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index 94e9cf6e36b2..7ea1a7d98796 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1,5 +1,7 @@
AUX python-distutils-extra-2.44-skip-build.patch 2560 BLAKE2B 2c027fe6875b1b0b94f7a40b521bfdf226be5add5634958395c637918363ea6ad98d82b7befbd95b3c566581719cd316afbf487ce30683427eddde4d49ff2818 SHA512 07808a920eeb5b1519778bcc9dd24186715b90b82b32b5c21a2e1754e6cb89057c3da856a250874777311fdd38de277161999f50e03af7a60fcc9b295450469f
AUX python-distutils-extra-2.44-test.patch 1020 BLAKE2B 5818c26d89980d5f1608a9d0ed59f4ebedecc942d5eee599a78b77ff331244b4969d265390c9e6b6dddd3a0886f2a39eaf7f4e7f631ab6dab9fcdd5dfc02cdc5 SHA512 3381a8ca6cd87635a260f37d349204cb5112718f7a2aa13b384d1c3622fa3e61685c2e4bdbd15e7f8421d2d8554a13cabbfd490e17975d5aa7084c293b161c55
DIST python-distutils-extra-2.44.tar.bz2 37687 BLAKE2B 3d7e3ad277440bfb6fbade8b890b95aad37589700b69a26ec9a5c30e97491871bc8c8f82b540131859d2ce82cebd3758f29ca510abe28046ffcaa0e7240fad3e SHA512 517222b4e34efba730db53ffeee8b8c8d96bd9d1b6044e6ca84c0f2c1d5c0e044240b899d460c50295615c94c513f7e57db3e34e5db6588a01ec92a73999f822
+DIST python-distutils-extra-2.45.tar.bz2 38094 BLAKE2B b8c0adcb92d07e087e10389c9671e9eca78a9a634d0092c1633e184fb9d128b006903ce8f2c9deb504b3d1557a8afc78e3edea7f1a2e95734c55099b4a21dd41 SHA512 04d2be290726d7ceed599031bfa960468c6a8654c8d9105dd77cb5744f6908d1c9a6732095692aebde1f1e042ef70b2695d41586663e4d539ee96247a39f02a1
EBUILD python-distutils-extra-2.44-r1.ebuild 1082 BLAKE2B e466ccbb2ca635c9d090ecc6a9e80181558ee4918bf1d6ca2a04df7b67775d0c00d9b6bd2a35fef3d9e6983054f9182dba0129cee05df61351210f239c7f41ec SHA512 17fdf960c10b6654bd19c2fac3d72497d3254fb44db577488a0e84221a968cf16665b3c6e059e1d0fc7016c8d0d1e79e3a755b54c8770dd1534ae9728ff299e0
+EBUILD python-distutils-extra-2.45.ebuild 920 BLAKE2B aa6eff79bbacae0546157626555ba8b46de2d7d12439fd0b761b87d649621e12f48a103842993a173794d7acb7f1a303afaa3bdc1d50dde0d4d7e35904406ac6 SHA512 689820557953e0e5dc7ef162ba8c35184a3cea23d33215445c8b6126c7cd47b86bba4f5129646a4f42dd1eed50986f3b55b07a07a8a06e406ff083f5205ddd91
MISC metadata.xml 339 BLAKE2B c7a822f45ad521df2cf6837bdc46e1e8473d8fac77428f80561dfd518b84b47353a37064bd0b9ad1e77441e7f376f0f005755d9c07c67e742c38b7dda02e7348 SHA512 2b8f9ffa8823ba2e9f1811782e17e8a6b3011c2096454b3dfa9373d085b4404f6a0afd1d8d9346adedaa01e09f4410c0d154ca74a00d770b8ad5da33a1a151a0
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild
new file mode 100644
index 000000000000..426f03e80fb7
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra
+ https://launchpad.net/python-distutils-extra"
+SRC_URI="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )"
+
+python_test() {
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}