summaryrefslogtreecommitdiff
path: root/dev-python/python-distutils-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-distutils-extra
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest5
-rw-r--r--dev-python/python-distutils-extra/metadata.xml12
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild41
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild54
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
new file mode 100644
index 000000000000..6cf06f58d39b
--- /dev/null
+++ b/dev-python/python-distutils-extra/Manifest
@@ -0,0 +1,5 @@
+DIST python-distutils-extra-2.38.tar.gz 27748 BLAKE2B 5f47e27dc639a6259a812bd618d35c4bc0a39362f3b7bf1a2e35331dfbd06b6b16a3030e125a8f5869770324a8df6eb446a5855639ed1b83379297509ea48891 SHA512 bbaea59a8f251f354e6cf3799b67c12225095cc869c7c4e299e719ad7bcfd1292cff99f95ab25f04fb9c3e2432da5ea614ee76154781388c47960fdf2c90a3d7
+DIST python-distutils-extra-2.39.tar.gz 27389 BLAKE2B 06deca885aa283e0a52e38c89f71637573d45d73dfbace5a06b4bbfa04098a7fa4fde1c2891bde5cc5ed3a3a65e31d243feaa8465a4fddb4623435e7a47c902e SHA512 e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e
+EBUILD python-distutils-extra-2.38.ebuild 1072 BLAKE2B 0daddc50346f7bd29cad9c4fe12828dfe7eb73ec8ba8ffec61d00426cd5766d7c5f6ab5ebab6599f17654cc5b68b40ed2adf3c75af7405359cabe6f350c4c049 SHA512 63894d8bc085ebdc9c9b13961448fefe88b55aca7fafedcae289d1b03fcfb41dadb8dc1847703dcc8e910aae7a528b4651c79240bac78d0cd000cbd8a13ea4d5
+EBUILD python-distutils-extra-2.39.ebuild 1456 BLAKE2B 7d2f7f7c2994eb5271e2741eb31a15c20c0ea47d16dbfeb7c5ee8d16a12228c0ac448246e88766001ba5e04e5edaf7e9358606cb698c92a6f90ff3c585169030 SHA512 84a61095999508262a61e36c8ec8f53c33d9cc791b704f27aa04f30f00169458209d3d4b1c03fa566602984f57ef1965eff4a716df542015fd1365822ff2d668
+MISC metadata.xml 401 BLAKE2B 6ba770986ed5364c9311bbf2a48957c0ec46f3c16e7718b564865b9ca7459f3c64cbcf6ee04c4b66564429e7f6714b0a128f83f2bd0d33f062b3670210d11858 SHA512 0dfe7658fe14d75a542a901de11983e7e0d8663b158032f5b8a71814c4caa93c14b4bc32e422c49a19550544c1b1fd4075be8a6644f0ea780bb23e1adc65b402
diff --git a/dev-python/python-distutils-extra/metadata.xml b/dev-python/python-distutils-extra/metadata.xml
new file mode 100644
index 000000000000..930ec08cf4e8
--- /dev/null
+++ b/dev-python/python-distutils-extra/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">python-distutils-extra</remote-id>
+ <bugs-to>https://bugs.launchpad.net/python-distutils-extra</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild
new file mode 100644
index 000000000000..dd6552011161
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/{FAQ,README,setup.cfg.example,setup.py.example} )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" -e "s/test_requires_provides/_&/" \
+ -i test/auto.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ local -x PYTHONDONTWRITEBYTECODE
+ "${PYTHON}" test/auto.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild
new file mode 100644
index 000000000000..855f84bbdd29
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( doc/{README,FAQ} )
+
+python_prepare_all() {
+ # This line is run when the file is imported
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
+ sed -i '/^unittest.main()$/d' test/auto.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ # The other 4 are broken.
+ py.test -k "not (test_pot_manual or test_pot_auto_explicit or \
+ test_pot_auto or test_modules or test_packages) and not \
+ (test_desktop or test_po or test_policykit or \
+ test_requires_provides)" test/auto.py || \
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ docinto examples
+ dodoc doc/{setup.cfg.example,setup.py.example}
+ docompress -x /usr/share/doc/${PF}/examples
+}