summaryrefslogtreecommitdiff
path: root/dev-python/python-distutils-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-python/python-distutils-extra
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest2
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index 2e93bdec0130..fbd1c7e3c0ff 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1,5 +1,7 @@
DIST python-distutils-extra-2.38.tar.gz 27748 BLAKE2B 5f47e27dc639a6259a812bd618d35c4bc0a39362f3b7bf1a2e35331dfbd06b6b16a3030e125a8f5869770324a8df6eb446a5855639ed1b83379297509ea48891 SHA512 bbaea59a8f251f354e6cf3799b67c12225095cc869c7c4e299e719ad7bcfd1292cff99f95ab25f04fb9c3e2432da5ea614ee76154781388c47960fdf2c90a3d7
DIST python-distutils-extra-2.39.tar.gz 27389 BLAKE2B 06deca885aa283e0a52e38c89f71637573d45d73dfbace5a06b4bbfa04098a7fa4fde1c2891bde5cc5ed3a3a65e31d243feaa8465a4fddb4623435e7a47c902e SHA512 e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e
+DIST python-distutils-extra_2.42.tar.xz 37996 BLAKE2B dee4cc950bb34027b60dcf58e173bae502a7090062e3c2218fd2ec562d6350f5872ed5c0865b89f1463bd35be0f365f23e05bb0220f70a944181af40df42ee60 SHA512 ff0df0a25a29504bec89970dbbf24d0b618e9f2d5d07a037f67778b86c92e880eafee86dd102b4ada4f280abd3102de9f4a4e47dbc68c1eaaa05fb492cbbae29
EBUILD python-distutils-extra-2.38.ebuild 1063 BLAKE2B ed1ba60ec0d9a2a4193550c54597a76e7e9d428670c0018e38bc0dd0ebb24ee5918f5d98d210851c74c7021cb01a3ba6b85390c1504faa2b568e154e5c37c206 SHA512 89eaea3dfadb3e385f17dc05eacf7d36f2766114be278e82a43851a1b313bda100b10dcfb03aeab42c59e8dda546ca45f40f47db4b5f1c24fc1838131416d320
EBUILD python-distutils-extra-2.39.ebuild 1407 BLAKE2B 4e7bca8828cf129a31ea16e0720528ecf4032e16871a7580d72914fcba0512fd5575ba11cfc1680ef9f8b580d10ddff5f28dc7f3b3dadf3bd584a909d238e876 SHA512 f75cb32a2df779dac30d8de71509323933f011cb3e113eb9b5768f32ce085ef1d96d177a1bd641a0001291406586e31ebe993bb5a150578b481277d442ee869c
+EBUILD python-distutils-extra-2.42.ebuild 1396 BLAKE2B d8b586a1da01d95893cc61f9bfa27547b4ace4597bf24dcf9eec71e86d94530156846763dbd34ca1905d47b0eaab24ca1ac22877969174cf1832fba76f3ddf86 SHA512 97362cc87b30f523fa52cf3f1760b96f23a9b4d51ccab9bc4b8edfaa79d61eaab74b9ac305d3bd40e619c990168e6bd627cfa515fb2f5a2d97d66d23039357b6
MISC metadata.xml 401 BLAKE2B 6ba770986ed5364c9311bbf2a48957c0ec46f3c16e7718b564865b9ca7459f3c64cbcf6ee04c4b66564429e7f6714b0a128f83f2bd0d33f062b3670210d11858 SHA512 0dfe7658fe14d75a542a901de11983e7e0d8663b158032f5b8a71814c4caa93c14b4bc32e422c49a19550544c1b1fd4075be8a6644f0ea780bb23e1adc65b402
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild
new file mode 100644
index 000000000000..3b3e02753ac1
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="mirror://ubuntu/pool/universe/p/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( doc/{README,FAQ} )
+
+python_prepare_all() {
+ # This line is run when the file is imported
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
+ sed -i '/^unittest.main()$/d' test/auto.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ # The other 4 are broken.
+ pytest -vv -k "not (test_pot_manual or test_pot_auto_explicit or \
+ test_pot_auto or test_modules or test_packages) and not \
+ (test_desktop or test_po or test_policykit or \
+ test_requires_provides)" test/auto.py || \
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ docinto examples
+ dodoc doc/{setup.cfg.example,setup.py.example}
+ docompress -x /usr/share/doc/${PF}/examples
+}