summaryrefslogtreecommitdiff
path: root/dev-python/python-distutils-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/python-distutils-extra
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/Manifest4
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild40
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild40
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/Manifest b/dev-python/python-distutils-extra/Manifest
index 62fd973bf08f..1b0b11486540 100644
--- a/dev-python/python-distutils-extra/Manifest
+++ b/dev-python/python-distutils-extra/Manifest
@@ -1,3 +1,7 @@
DIST python-distutils-extra-2.45.tar.bz2 38094 BLAKE2B b8c0adcb92d07e087e10389c9671e9eca78a9a634d0092c1633e184fb9d128b006903ce8f2c9deb504b3d1557a8afc78e3edea7f1a2e95734c55099b4a21dd41 SHA512 04d2be290726d7ceed599031bfa960468c6a8654c8d9105dd77cb5744f6908d1c9a6732095692aebde1f1e042ef70b2695d41586663e4d539ee96247a39f02a1
+DIST python-distutils-extra-2.46.tar.bz2 38178 BLAKE2B 66bded2a07a65a45e7b5a36c1846a0927db8cc38c158754c660ea854244736325b9b186de1739666e228199b32ff6184676a78f132689a996a9a417562dc0926 SHA512 78dd97f40e805dd106fae279770fbd28af75a01a0c514cdb937dccd87948cb8ae2413dbab43d624365b44a29e6da7b0a1290502a0a0d63e8abb700ae9b9c5cb1
+DIST python-distutils-extra-2.47.tar.bz2 38346 BLAKE2B 2f9ad3c8c429570bd45c06af3eb2b12bf5f539c49e3b3a40c3558e67a4e4fc9f0bca0c4217bac6c8792e0514d75ac2b4b112dbeaffa96d626fffcc237860342d SHA512 b848b8ccfd84289e5482ba264a8d8d81cdbeba97358c9fff6fb02040eeb740bacfcc19b302e56a95b400528f7e03390ea4073b8c80d1e5a5e61e1b6c46b39648
EBUILD python-distutils-extra-2.45.ebuild 872 BLAKE2B ca19e571d86a908c826099ef9127ca91a8c47ceaee03b1ec4bb1ed3a04ed12464ccd2369dfd4de71e839a274b3fe81a994440c6b8a70ecb9fc215430134bc088 SHA512 9b3a89a7c8ed0e0f5960636064044c36cdb46847c75f7cfe0a0a2f459737030b670268ce71c2d888edcb8847401a072bc3f52d91fb501c176686e91f646736b9
+EBUILD python-distutils-extra-2.46.ebuild 957 BLAKE2B 1e0cf322dcdd07d8a468f6ac94967289de264f9146cd0db3649e0431b325a679c56286f62a3257e45a9f98a4793e0695497a6d413dfb949e49be219ed865a078 SHA512 5161b83a90a5f386302ec392ae7634b6ee5dd6c8fb0bcfb5003385269cec1a8cab109f84ef7c7a0bae5b38bc75e23e60b9f626d1619397850293832481a95622
+EBUILD python-distutils-extra-2.47.ebuild 957 BLAKE2B 1e0cf322dcdd07d8a468f6ac94967289de264f9146cd0db3649e0431b325a679c56286f62a3257e45a9f98a4793e0695497a6d413dfb949e49be219ed865a078 SHA512 5161b83a90a5f386302ec392ae7634b6ee5dd6c8fb0bcfb5003385269cec1a8cab109f84ef7c7a0bae5b38bc75e23e60b9f626d1619397850293832481a95622
MISC metadata.xml 340 BLAKE2B 21821b0f3d5483e62c4e84a0d98acb7a9984cc7a72d9c3fd140dd37fb2b93b724c8b92a80da9880d2cf314cb457f7f328efa5313fecc361dcebb1d4ea61ae504 SHA512 a7413179a36b347c297d304e24ea7ba9995fb8e66d2d0498923da83dde5e657855e6d875bc9f10b62f4c7342bf0e07a42bb0c1033d74b7a07422d29273c46857
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
new file mode 100644
index 000000000000..d00792e6360e
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.46.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/
+ https://launchpad.net/python-distutils-extra/
+"
+SRC_URI="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )
+"
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild
new file mode 100644
index 000000000000..d00792e6360e
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.47.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/
+ https://launchpad.net/python-distutils-extra/
+"
+SRC_URI="
+ https://salsa.debian.org/python-team/packages/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-util/intltool
+ )
+"
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}