summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /dev-python/python-debian
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-1.0.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index e76e1e398d17..e1d9a3d6fa2d 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,3 +1,5 @@
DIST python-debian_0.1.49.tar.xz 191388 BLAKE2B 590e6f7877684caaa5a74f06d335bcf7808960968209cf18bb2cec7e81f33a3b0ff458bbe30264ae5fc015de9357dddb1522b5fd93bf33d0a7fabef1b7dd98f9 SHA512 201ceecdd8c1d3dc0cca0f661407bcfb825a1cba07c528858cc1123ab16afe0df50e338c8cd82ea24230812a9cc136220bd4f0dccbac19ad53efe48eaa25cf6f
+DIST python-debian_1.0.0.tar.xz 197964 BLAKE2B 38e9ce2f1bbb15577e18189ad1a26d230f24ef7d20490556ab72149f68e5945e777018abca256d49020f4985f13953b6fd1640042272df763af38a8e57eb3766 SHA512 86d58c5185580010773f4d7236aa84276828a094f07bc8fe11d77c2cdf8a4b911284299dd2c2728dbbb802091b4a81b5ff2876404dfb9d944df1d996bb369228
EBUILD python-debian-0.1.49.ebuild 1034 BLAKE2B d1242f63aac6531b6112af697e56037ced54aa4625d7cda87f743a3097bcacf9b5083864228736271149c2cbd3ea9bbed58dc23f461f4a89e24df8d0b7f1da66 SHA512 007d8726fce7a6bda5fe00a3aca554770e318954e54dcda42a1c03e4527a9c29c04c98ef4f0923f2379715de3324438d9e67dd4d9759d9f2d4cf15ae3e77fa0d
+EBUILD python-debian-1.0.0.ebuild 966 BLAKE2B 9cff809f1e8a7130a4577b044c134d010b8c0a0dfcabaaf1129e1b0b646b33868e2bfb3581e7f7a721f56af57c617e2e19695cff785adac49c1ae5b34601b790 SHA512 949904c4735b6945d160829bec206aa1a5f4ba46441ac004074c270db3bdd3315a23810f46cd82cf5e7252b6cfbed604067f139926ed504fa798df944708ffec
MISC metadata.xml 448 BLAKE2B bccb39bdfb24e81bc05028fc92033468f5256be096cb409b4413f69444d59d3d9a3469047337a7fec79ac707ddf4d269b44b20c725f7fc4935bd10335e1f9374 SHA512 8e3fb6ca4bf305e23a51ff56cf84648aad1e96d36aa7a4fb138f7136ea77a6a76a8985557ecb1c9da962479c8c9e36c253655d6e6602c1833f2a2230b44540aa
diff --git a/dev-python/python-debian/python-debian-1.0.0.ebuild b/dev-python/python-debian/python-debian-1.0.0.ebuild
new file mode 100644
index 000000000000..5f1d288769cd
--- /dev/null
+++ b/dev-python/python-debian/python-debian-1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2011-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # silence false positives
+ rm -rf debian || die
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" src/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ epytest --doctest-modules
+}