summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-debian
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest5
-rw-r--r--dev-python/python-debian/metadata.xml12
-rw-r--r--dev-python/python-debian/python-debian-0.1.28.ebuild38
-rw-r--r--dev-python/python-debian/python-debian-0.1.31.ebuild41
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
new file mode 100644
index 000000000000..eaddf3640a35
--- /dev/null
+++ b/dev-python/python-debian/Manifest
@@ -0,0 +1,5 @@
+DIST python-debian_0.1.28.tar.xz 292404 BLAKE2B 78634043fc0dabd378bae171a485931b080dc0d31cc7e2ea448c000a1c4250e322f900cf0a0a4c3a8505af6f10da692d0fad948bc253ede7a38e4fe98831924b SHA512 ffbc924fe2dfd5790d49aacf80109bbaa18126bb8d6c9b8ffa25e9ed8b1cdeb28024a8dc202587682088e2e558da1642385faa4afda925cbb2edf6f304592a0d
+DIST python-debian_0.1.31.tar.xz 295720 BLAKE2B 3b3a68ab5604571355a15afac181e488c278ca78ab4c8a6cba4c392a0a89fd778bfd37e69a369d50fbc72f5080cf37fdbd31771f5d973c386795c436112ea347 SHA512 d2bf071b088e53ac132f91e5983c092bddb9736b3fd1394dfd2654fb8b6af7f89982af8debba8c4af21086d4f8a3ef86393fdef25ef18bcf71dcb00a60a8ae5b
+EBUILD python-debian-0.1.28.ebuild 984 BLAKE2B 6a19343653ea6fc582cddeb6b80e425edd85523034db18850d74d24d97f67e6c9e0d7145c665de1832b0585b22b1947ccca4c8157f3ff1ae46197580b97a85a6 SHA512 365ceb69505d32076eb84ce231049ebedb06e79a34d69ebd9658ad515ff9148f874e03b00a07604dbc425fc66ff661e465dfcb19931c058f17b1fe3a429b394b
+EBUILD python-debian-0.1.31.ebuild 1012 BLAKE2B 5dd74b8cc4b46986aa9f4fbdf24cacf00015f9244edfbeee83ceb39249c4a2f49164d87120e5e8061413167f327e12e366045e78ac4e21645553f31058a391ca SHA512 cba45cafd403488173b1fe5ffca9fc65b38dc5fe70072305a53a06b1b6e7a35ee19914cd1c10f0200fb39e93079e1d82c1742dccdc8ad329c689999f7ba4a38c
+MISC metadata.xml 357 BLAKE2B 0b0bdfba85c4141c9931d4a363d204fabd9dd2e22b4d7a4af11bd97837fe6ab0cf0161fc154f396198b12d0084af54702a4f0ae0ef0b64f4d8c9efdd131f448a SHA512 452510eeb22c1db33118dfcd518488f42be0789b5607c9b76d316b14c6d1a474b6bfeddfc4034389a136c408bc4180ad704b6e1b0eac1381f9a77284b7016e39
diff --git a/dev-python/python-debian/metadata.xml b/dev-python/python-debian/metadata.xml
new file mode 100644
index 000000000000..b45b94729bb6
--- /dev/null
+++ b/dev-python/python-debian/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-debian/python-debian-0.1.28.ebuild b/dev-python/python-debian/python-debian-0.1.28.ebuild
new file mode 100644
index 000000000000..427a310a47e1
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+RESTRICT="test"
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ # Tests currently fail with >=app-crypt/gnupg-2.1
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782904
+ pushd tests > /dev/null || die
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
diff --git a/dev-python/python-debian/python-debian-0.1.31.ebuild b/dev-python/python-debian/python-debian-0.1.31.ebuild
new file mode 100644
index 000000000000..685365963e1a
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.31.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i -e '/import apt_pkg/d' \
+ -e 's/test_iter_paragraphs_comments_use_apt_pkg/_&/' \
+ lib/debian/tests/test_deb822.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover lib || die "Testing failed with ${EPYTHON}"
+}