summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/python-debian
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.44.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 309ff423b81c..4fd7d1e93c59 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,3 +1,5 @@
DIST python-debian_0.1.43.tar.xz 175832 BLAKE2B 2b43da25392c844a3c8fa8e159695ef4c871c6620be88d286abde31b9285e3f005e3c20997617d24014fe94a1a3c446c8721f8d92c35018ac308da8703788bcd SHA512 510dd37ef65be2ee0f9c4c4c15010b94fc7c05c621de2cb25fee4f6e741f51dff2e4cdc333313bac8269bfa621533217b3f72ecbd8b0b6368aa52c54e5237bb6
+DIST python-debian_0.1.44.tar.xz 179372 BLAKE2B 39d19c46e956231cda7c1fdb3ca89f8ef579d61e6bff06b35114184b2596516b3a01f756ff8e34e9a0dab669658cce7b8fdbfa39ed770df376acf6c4c6fb1401 SHA512 34c627cf32647f196a4b41a8913fd9aaefcfd6c96d21cc8f9798723ac11dac371574f62af9e549437188f2f492cb80445e33f35c72b6fa8212223029371a7b33
EBUILD python-debian-0.1.43.ebuild 910 BLAKE2B d9cfcaed8155908f5f5368ffa0b024672055467921c8244e81480da9708262e4379ae8cd6abc5b1e5013a114e0fc33b64897c81fec2672d0f45402941730b33a SHA512 5d9e19affafacb78b99ec9d1a4d2b1e575b649c8191d0afe1371758f0ab1e0ca1d58d2087c9bd513ac0becb58dbdac394315076706df9efb7ab70d25013bf808
+EBUILD python-debian-0.1.44.ebuild 966 BLAKE2B 603a89e178cdde7e72085b616803c263c7b4874fb6abbf71fb306d81feed10d6fa3010476e7fd177d69764bdf0a7332cf08ce8e45bac37820048bcc2fdfef654 SHA512 3550de40d71c5c7aef4db108121109cd3e79deb0b7e17c3ee446484ceac6256ed31271f58be72422022a7fe90d250151b9041d527b5ccfeb4a81e2695787f452
MISC metadata.xml 448 BLAKE2B bccb39bdfb24e81bc05028fc92033468f5256be096cb409b4413f69444d59d3d9a3469047337a7fec79ac707ddf4d269b44b20c725f7fc4935bd10335e1f9374 SHA512 8e3fb6ca4bf305e23a51ff56cf84648aad1e96d36aa7a4fb138f7136ea77a6a76a8985557ecb1c9da962479c8c9e36c253655d6e6602c1833f2a2230b44540aa
diff --git a/dev-python/python-debian/python-debian-0.1.44.ebuild b/dev-python/python-debian/python-debian-0.1.44.ebuild
new file mode 100644
index 000000000000..3c07375c1483
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.44.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
+ > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}