summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
commit005a5b259b876973202153b9c5c5e77bea56df6c (patch)
tree62e787239ec670df6ea942997fd18c32f3879774 /dev-python/python-debian
parent048bd060badd229e3bb596029874760a86d27060 (diff)
gentoo auto-resync : 30:08:2022 - 10:48:18
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.47.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index cb4dc9be5e93..167d0e94bfa7 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,3 +1,5 @@
DIST python-debian_0.1.44.tar.xz 179372 BLAKE2B 39d19c46e956231cda7c1fdb3ca89f8ef579d61e6bff06b35114184b2596516b3a01f756ff8e34e9a0dab669658cce7b8fdbfa39ed770df376acf6c4c6fb1401 SHA512 34c627cf32647f196a4b41a8913fd9aaefcfd6c96d21cc8f9798723ac11dac371574f62af9e549437188f2f492cb80445e33f35c72b6fa8212223029371a7b33
+DIST python-debian_0.1.47.tar.xz 189036 BLAKE2B b929b3785064560bbad202d95d88fa330a9fb34e0dc4338865ce17910c9ff986696778dba847097fa1ccbb04ad6b298a5b84e4a550e038ca754a598d78f7cbef SHA512 fdf37476d4658b790ea4bbb43fca43a627cc569881f9e45666eae4221ddb71d57eba7d009e06e8e2864cd41c7718b9bf41e319f6fc0785549b6171de981b6ed7
EBUILD python-debian-0.1.44.ebuild 963 BLAKE2B 71e8142ac149f35932ed279d9710442fff2b8a142274ca2b7b223af745e091a3cb9bbac14ce90694990b4ab036ef8156b5a422d57bce5a0aa30914ae0ed24c8c SHA512 3d2a3f4c197a54f1bef45d9efc312dc8203d409707a275551f8b69a4d9af03f891c8f9b1f422df49e18bb29e6a9a149f9c9d2aeabce88b2665c265d4ab6cb31b
+EBUILD python-debian-0.1.47.ebuild 966 BLAKE2B 603a89e178cdde7e72085b616803c263c7b4874fb6abbf71fb306d81feed10d6fa3010476e7fd177d69764bdf0a7332cf08ce8e45bac37820048bcc2fdfef654 SHA512 3550de40d71c5c7aef4db108121109cd3e79deb0b7e17c3ee446484ceac6256ed31271f58be72422022a7fe90d250151b9041d527b5ccfeb4a81e2695787f452
MISC metadata.xml 448 BLAKE2B bccb39bdfb24e81bc05028fc92033468f5256be096cb409b4413f69444d59d3d9a3469047337a7fec79ac707ddf4d269b44b20c725f7fc4935bd10335e1f9374 SHA512 8e3fb6ca4bf305e23a51ff56cf84648aad1e96d36aa7a4fb138f7136ea77a6a76a8985557ecb1c9da962479c8c9e36c253655d6e6602c1833f2a2230b44540aa
diff --git a/dev-python/python-debian/python-debian-0.1.47.ebuild b/dev-python/python-debian/python-debian-0.1.47.ebuild
new file mode 100644
index 000000000000..3c07375c1483
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.47.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
+ > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}