summaryrefslogtreecommitdiff
path: root/dev-python/python-debian/python-debian-0.1.47.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
commit26f79803004cb53e92cf2f0e889de89979385aa9 (patch)
treed46d17cb971a2dffbe96669e4ad8d341eb5ee3c7 /dev-python/python-debian/python-debian-0.1.47.ebuild
parentc5572b13d51970d6603acd131f27991cc1b66a79 (diff)
gentoo auto-resync : 19:11:2022 - 13:00:31
Diffstat (limited to 'dev-python/python-debian/python-debian-0.1.47.ebuild')
-rw-r--r--dev-python/python-debian/python-debian-0.1.47.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.47.ebuild b/dev-python/python-debian/python-debian-0.1.47.ebuild
deleted file mode 100644
index 15b1e315ea43..000000000000
--- a/dev-python/python-debian/python-debian-0.1.47.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2011-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="
- https://salsa.debian.org/python-debian-team/python-debian/
- https://pypi.org/project/python-debian/
-"
-SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- app-arch/dpkg
- )
-"
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # See debian/rules.
- sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
- > lib/debian/_version.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # See debian/rules.
- "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
-}
-
-python_test() {
- eunittest lib
-}