summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
commita625efe29cec7f7c437cf33a956ea99eed1e4bd9 (patch)
tree3132969a9e093b34d3bd91ee6110a1111a965630 /dev-python/python-dbusmock
parent1ff514162358897632ab329134c6bc75af618f10 (diff)
gentoo auto-resync : 24:02:2024 - 11:40:42
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 5280abdd85c4..19e406e38edb 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.30.2.tar.gz 98188 BLAKE2B bfcac761933c2d433ddc7b53ca87ceb395dba23b73fc4478e0317cf1da6693b3b55cd7d5ca814425d74714f8b7544255f07a536fe7c1a1949dee30996a2761a0 SHA512 a34c4660fe50b9551274626b19959dbe985e112429d2eb68811f3cc37cc017f8171eac2e2b8c262874678e24f7fb3d1f39410cd977b59f501973de19b6ca3a13
+DIST python-dbusmock-0.31.1.tar.gz 98739 BLAKE2B 623aa336c66ad1743d1b86421184c13d647970ffe1a7ffbc2e100c179fb3af98846c96f0a8baccfb9a1f47aa2e380d0bff91c17f967d9c798a97a5fef43bc376 SHA512 5d409e979046cf301c5f8604b43c67abba111315d40e54b59cc5ff6e8fe3bb006591fdac877f750b3a0d56f840337f136b99dda9237de1b00718ef85a3bfcf7b
EBUILD python-dbusmock-0.30.2.ebuild 1062 BLAKE2B f903331b483efd63a88b0663964ec954aad45739c241d45959461bc51a02dbd9c57d4fcc3cfa5dc896fde91398097110001e0cd159b210d2ee63b586bb6649f0 SHA512 8b35eb7107d9165a9f5e80be02c722fafc282005aeccae729ad78976e29160af1d8f36ff56f1727eebd646dd9d388e4e6256d5e1cef4f2a1d1087e17496e9692
+EBUILD python-dbusmock-0.31.1.ebuild 1069 BLAKE2B 57832e67b6a1b21a54d0b9c843828f49f42e8938ca09a8e5273f6c6300f1ef153068a0ef4b11a8bcb37c490563dd72832ee301c3f9f6911d5f91fb1286316fe3 SHA512 3d7202ea50cffd075bf3d72313a3217c72b6cc5fc972e14ce7de7df60d6641720c35e9e7a71b8831ad805347ec728dc60888f89ef32801faf4d91dfcc36fe3fe
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild
new file mode 100644
index 000000000000..4915685b8472
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.31.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ distutils-r1_python_test
+}