summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-python/python-dbusmock
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest4
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.28.6-r1.ebuild (renamed from dev-python/python-dbusmock/python-dbusmock-0.28.4.ebuild)13
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild40
3 files changed, 9 insertions, 48 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index cd66f5372c26..ca9e181a1192 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,5 +1,3 @@
-DIST python-dbusmock-0.28.4.gh.tar.gz 86900 BLAKE2B af6ca30e15e803e66aec63d40d56d121c93e9fe253d7640111104c8e8c0ea5e0491b53f551d6b454ae7370cbbb7f8fb14c07b5be92a8425efa39e04f962311f5 SHA512 f388425ebb68c20b5110a831879bee0d7d0a3941687fd61c9975c4aaa9950b05709e7fc2a9b885c89935a915f473bb7a9b97e93ca79cf3dc6769911a66aeaea7
DIST python-dbusmock-0.28.6.gh.tar.gz 90579 BLAKE2B 12b4ee02ae6b828b908b203a351f5b88d25193bb1250a0d25bc90b0ac2a244c4ef577bdacb2dbbb9220ba93d785791d900c9035d8d5c3a21aa744b5f850d16c9 SHA512 1efc1a42fc5cc56d683f0f4d022877020f15d81a557c54f47619c704ca2f67716c1fbdb890f987d01f78b7786528a71de8dbfe84228baa41351eb751fc4cce61
-EBUILD python-dbusmock-0.28.4.ebuild 947 BLAKE2B 6591f8f209ed1bfe25b271ec08ae8eb32d504897924556c5062c5308c2d6df2f9a249e40ed251af237a96e0609397d3278f0c6e73abd6c73df22edfb63731e29 SHA512 a6f95e9d34445f875d6374ae906f68f57b96aae002d1b3047a7071266991a28c3eb2660b8ac919ecb1a38978e1d51c32e65d859555e68cd459ea427d2d817450
-EBUILD python-dbusmock-0.28.6.ebuild 947 BLAKE2B 6591f8f209ed1bfe25b271ec08ae8eb32d504897924556c5062c5308c2d6df2f9a249e40ed251af237a96e0609397d3278f0c6e73abd6c73df22edfb63731e29 SHA512 a6f95e9d34445f875d6374ae906f68f57b96aae002d1b3047a7071266991a28c3eb2660b8ac919ecb1a38978e1d51c32e65d859555e68cd459ea427d2d817450
+EBUILD python-dbusmock-0.28.6-r1.ebuild 1016 BLAKE2B 5349ec64090a36fa6605e7ac4da695ea6d586c340747de1f8127b331d2b61c15b332fd8a209148cd4c2f33e76e1b745e76c599635445609e8cb24b39dc0596ff SHA512 64e2fe3ec0ec086f1ee6cab33aa5f8588d94f703b68706fafc3014afa055bf3a3fc8edf65313525736457231b6c4b6a8d5034ab93ace80e988b565ebf64ded21
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.28.4.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.28.6-r1.ebuild
index 35d6a870d0c6..c43a7378ca54 100644
--- a/dev-python/python-dbusmock/python-dbusmock-0.28.4.ebuild
+++ b/dev-python/python-dbusmock/python-dbusmock-0.28.6-r1.ebuild
@@ -28,13 +28,16 @@ RDEPEND="
dev-python/pygobject:3[${PYTHON_USEDEP}]
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
-src_prepare() {
- # needed for unittest discovery
- > tests/__init__.py || die
+EPYTEST_IGNORE=(
# linter tests, fragile to newer linter versions
- rm tests/test_code.py || die
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
distutils-r1_src_prepare
}
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
deleted file mode 100644
index 35d6a870d0c6..000000000000
--- a/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="
- https://github.com/martinpitt/python-dbusmock/
- https://pypi.org/project/python-dbusmock/
-"
-SRC_URI="
- https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # needed for unittest discovery
- > tests/__init__.py || die
- # linter tests, fragile to newer linter versions
- rm tests/test_code.py || die
-
- distutils-r1_src_prepare
-}