summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
commit868fd5dc8aab84930cfaa5252b8be06b35552765 (patch)
tree0c0cebf818c30c6f871f00ce1e7599775a7e561c /dev-python/python-dbusmock
parentf7adcd4ee556b2c3a420239c13fb74113d791f6a (diff)
gentoo auto-resync : 15:07:2024 - 12:27:33
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.32.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 5106364e502d..99d7f2654cc1 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.31.1.tar.gz 98739 BLAKE2B 623aa336c66ad1743d1b86421184c13d647970ffe1a7ffbc2e100c179fb3af98846c96f0a8baccfb9a1f47aa2e380d0bff91c17f967d9c798a97a5fef43bc376 SHA512 5d409e979046cf301c5f8604b43c67abba111315d40e54b59cc5ff6e8fe3bb006591fdac877f750b3a0d56f840337f136b99dda9237de1b00718ef85a3bfcf7b
+DIST python-dbusmock-0.32.1.tar.gz 104265 BLAKE2B 78357a767e8f008463c69b55b57a02016c1aa1a392dc7a1ef3392020af839ef553ed6ff3cadac12a9c175efccdb29c7f3ed74ab7abafb0436a760dbe3193fbc6 SHA512 14b71c5d0a760fd1e8609815e4ae702ebc5c9f1f3c3e1bd930da616350b63b7fdbf99c7d584f5a834857798fb1cad56347d6a1cf2bdd758f9100180b0a7e725d
EBUILD python-dbusmock-0.31.1-r1.ebuild 1195 BLAKE2B c44d2e49b674b901c40378294684d7139f686624623b97fa0bd2357aa8df558e6877df7c04f9eb05308f8ebc0e9bda12af9cff4ea8c5f2ece9bf783e90d4d3a8 SHA512 5490de4e90e73cd0f91b6eb303d77a9dacd2a66cbc536c40af7342cdf0a26fbb546e5649736167c191073570561564de69248d3e313c9edfac8ad311a0507ef1
+EBUILD python-dbusmock-0.32.1.ebuild 1202 BLAKE2B 23e812468ccb3a1c1e9d8d922744770caa8d8fda69d13fe9b11c2612cc071d5bdba221de74996701495c3151c24cf42550a580249172ba17aee527700453dd37 SHA512 3a528f25b411e7aac1cf7042da5a608b5058bdc1f2597e921d48431768c5996d832f60319731308a827c3081413e473f6e1211f96dd3b97e70004a72d73e1d56
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.32.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.32.1.ebuild
new file mode 100644
index 000000000000..50edc076c019
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.32.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests are fragile to long socket paths
+ local -x TMPDIR=/tmp
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}