summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 01:44:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 01:44:21 +0000
commit4560e1a95e1072b051371c59aec78b15e4787ded (patch)
tree094ce9f8e6716977f66ede36cb7a5c7725af0f04 /dev-python/python-dbusmock
parent60360664173979c416f4acb44f2fb2368922742d (diff)
gentoo auto-resync : 24:12:2023 - 01:44:20
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 006da4d5a9ca..a5c3334f1da5 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.30.0.tar.gz 98201 BLAKE2B eb519dc526d4e3ab804c3415d223d77462e944bac8d03dd64fbe11f8a5d875ebad1643230b93d1d51cd4a979eed24e6b97d0744b115d28d233b4d1239ec04f01 SHA512 280a8ebfe12a0f5b309d5b807547ed521c80c9899fdc89abaaee238621cf94d05f8413ab2908ca331f9d3ef1c610234dafbd912f8590f18c7d9cafe470beece6
+DIST python-dbusmock-0.30.1.tar.gz 98206 BLAKE2B e7617e61f2dcd28ba01f5a4572250f1be756640a7751353c5adabc7539897a8f2dce1bf0f0233ed6dec52703d0cf989ff0dbdc3a526a299691f94ee227a3167a SHA512 dfa27c94d71e132ef56615cc02f2f9733ca55366b5e88f023ddc594b39c2239b460389e4b53981493d627e8c117542fa5ec82f0f4ec407ed6e825e30f5d206ae
EBUILD python-dbusmock-0.30.0.ebuild 933 BLAKE2B caac7592bae5ce66563db91cf544b02e9934959120383a0295a8e3a585d4e300c7aed436693dbdfa453308f8ac84ebfbddbbae3828449690b467945b123333ac SHA512 4b1424b782cfa4a21ec99890c1eab58a3b09cd6cb21bdff8d07f8e5687cc82803136e23e6a0e6d22011be698e3d055e2950f47f9eb134a9fc1de1af6bc18aada
+EBUILD python-dbusmock-0.30.1.ebuild 1069 BLAKE2B a62a25a7b3edeffd0968a79b2db8140d5a5ccffe21594a932ba952053445928c05cc01c6e709601eb417e95491a0fe20d9b39c6518a41b4446493bb7bbf11465 SHA512 c6ee41653a47811d56828b8d583eabae72e19fdc4dec7dbf478918e7f4e2c42bf215e22cf8c1c2776cf9d236b8f7e874e4ab5dfbe73ad9f85c44661ad4add8a2
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild
new file mode 100644
index 000000000000..e91d1001c936
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ distutils-r1_python_test
+}