summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 19:00:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 19:00:45 +0000
commit42d100735379ec54a77539383203e971a7ab8440 (patch)
treeee1d9d9ca8766e1b2d10e8ae02838bb8170c49c4 /dev-python/python-dbusmock
parentfc2ac03133775e16cea65c56db9b246440e8d824 (diff)
gentoo auto-resync : 21:03:2024 - 19:00:45
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.31.1-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index c6cbfa88d8eb..9ee3c4801023 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,4 @@
DIST python-dbusmock-0.31.1.tar.gz 98739 BLAKE2B 623aa336c66ad1743d1b86421184c13d647970ffe1a7ffbc2e100c179fb3af98846c96f0a8baccfb9a1f47aa2e380d0bff91c17f967d9c798a97a5fef43bc376 SHA512 5d409e979046cf301c5f8604b43c67abba111315d40e54b59cc5ff6e8fe3bb006591fdac877f750b3a0d56f840337f136b99dda9237de1b00718ef85a3bfcf7b
+EBUILD python-dbusmock-0.31.1-r1.ebuild 1099 BLAKE2B 5892302feba8706ec2b9b9178d1ac3393f887fed269eefeb8fc6464e12ecc0ce0b2e76c818351bc23da8583d74dabe393ccd66760a303627a62973d7fad61e97 SHA512 7eef04e02cc69533ff668c615e85df95eaa7be1091527e78c41b2abe1915de233231c77d11074de3d24b1297cae84c5f5914b7ecd1bbebdcfbfc21d0a970be1f
EBUILD python-dbusmock-0.31.1.ebuild 1062 BLAKE2B f903331b483efd63a88b0663964ec954aad45739c241d45959461bc51a02dbd9c57d4fcc3cfa5dc896fde91398097110001e0cd159b210d2ee63b586bb6649f0 SHA512 8b35eb7107d9165a9f5e80be02c722fafc282005aeccae729ad78976e29160af1d8f36ff56f1727eebd646dd9d388e4e6256d5e1cef4f2a1d1087e17496e9692
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.31.1-r1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.31.1-r1.ebuild
new file mode 100644
index 000000000000..014066c58a8c
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.31.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ distutils-r1_python_test
+}