summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /dev-python/python-dbusmock
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.24.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 3964fc3c55e4..6862a20c7d21 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.24.0.tar.gz 81907 BLAKE2B 5fc8653228d9278c74e623d385c798ba078da5d8309a95e88a893d3ceb1736568f93196defcde1845bfee193ec2e7abb4197a663f612dfe4ff58ac9c0bb189e3 SHA512 531c2d427da28098d7dac91cd5be1c38be15dfc9495314a150523e56c10ffda846667dfda39cc47c8278ad41800fe39d6608f24da44ff2ae7d53f0413826d96c
+DIST python-dbusmock-0.24.1.tar.gz 85781 BLAKE2B 2364ace9354cf626354aca5ada8b6fffe08dc742ffcf9f734c7214d5b0e982cfefdf238063e6b077cb1da832e758eb4eee74c00200f11927117c2faf9c72785a SHA512 705c974be203ae9104a703146e40420c59342ec1a6f3804e1d8e81c13401e95f5850ecc6e2b6e16bda4c9cc9f6ab0f82b5c829f4af947ff7d337ab8e63534596
EBUILD python-dbusmock-0.24.0.ebuild 833 BLAKE2B 788ebd32acb35c37362a6a8d2f54b714a3331e0bcd215bc4c3469b1225e3504980def80ff2bfcc079a743ad3d3ebbbd343bff0ddbf03b59fdda4588436ee07a4 SHA512 aa55b9d13d6973bf636e76577f6daeeef7996894e521e4958536bce72179ee40769d381eef32ec4fdc3079cca888f919134856d467ce28d5cc0004a8dbdb2089
+EBUILD python-dbusmock-0.24.1.ebuild 840 BLAKE2B 2e3a185989812753a4a232f4158d02baa6344d5b9d0848a4532963b84869e3998b18e2b3b51a30ca41fe367268d6e2fab7036e8d1a74daba4ca33870f8c58bae SHA512 6ff827cf08f2f67b0026ed2cc89172fc50a38ce141b751d4e9dae552f8dd580c50bc4ba7e767440080c8d61ec20489302e2b1c79ab14d03a608bb05f31a0c244
MISC metadata.xml 457 BLAKE2B 7c93de164cfb7badf62932420c9fff4eb07e2247ab2293f5299649e79fd1b8b8d51b30a3c685d9d88043e4e4067c557961be45d9cf2fdf1a13bee5547934eb98 SHA512 0b9ece97d74dc9a74fc9a3f55b1561c7f1473ce483ee7be53f875c740d433409b846161821d44e48c0a5988b5999e5704cf5f6afa2436f57fd1b654518ce1f87
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.24.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.24.1.ebuild
new file mode 100644
index 000000000000..aa54623eb206
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.24.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}