summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild')
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild
new file mode 100644
index 000000000000..9890f3764249
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.28.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}