summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-12 13:40:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-12 13:40:16 +0100
commitb4ef58ede68341d0e00d761505857e965e2b4231 (patch)
tree94723f8dfd3de9243bf2ae39d9deb2ee78c9719f /dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
parent9f3ff9d79a788d420003387392ec40fd0548efae (diff)
gentoo auto-resync : 12:10:2022 - 13:40:16
Diffstat (limited to 'dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild')
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
new file mode 100644
index 000000000000..39f9ae8e9046
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.28.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}