summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/python-daemon
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index 1c0a68e2f611..4a461c9d6022 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,5 @@
DIST python-daemon-2.2.4.tar.gz 80775 BLAKE2B 3f260993a2207e6467db03c456d9f8621d1f3252236b6d49432ff14c1039416db901feb5d405620106d02ae2ea186fd0b10183156f31d17f9f4fa62964fbd333 SHA512 9a7a4e23e126f05e4c1c503f15401cddd758c5f9195c370997060ca1bbfe71cc51d82d3ae16bcf0023c28fa50b0b8d6cd406e515b27725ffa9fec10fde3ed64a
+DIST python-daemon-2.3.0.tar.gz 82831 BLAKE2B 6e7fa082a513827283f46044347dfd445633db0d1781a33aa1bc5b14c340da784310ae6bd07d6cf3673cd05cb14a9d090ab51857d26cca52d09bc8c3b195360f SHA512 30bb70821aae720d09032c8c666524fa9a1a486314ffff73eb161231a1f2b954914295b4ad41f9c8529bc045fb6d0f89256bc59f8979a4f8a6698e9bd4d7441a
EBUILD python-daemon-2.2.4.ebuild 802 BLAKE2B b2778a40b40c5c93727913d949cc31a1d0e66af86a034823b2a92c51936a314ea6da05c3060beb810cd3984305ba7551c9055d59d18ad64e59f75f69e094826d SHA512 4532d4f8e9b20424c82627924310edf806818959365bfa1d27c166879304b0fccc3dccffdd634caaeef1ea979f1b4e28b69f684324f6f015881e2b3be54cea71
+EBUILD python-daemon-2.3.0.ebuild 706 BLAKE2B d2239a9de8344a6fcdabed305605b0d0b35fa556825a6c0b9701489959e7928fe6a61294cf29bb31fcbf1306a92bf4c5bca0966d09ab3a5ee5c1814a01c7dec8 SHA512 63e9d3af69fd4cbbda430aa9a0fbbd9b7fabc06ac351f83cc334e07834a7dffd584f305d2bc0e4e49156ffb82350c123031507046f59cf7e75b719be10abf310
MISC metadata.xml 340 BLAKE2B 8b44be0af694459080c54e9611780e3c5b1802a54702f38d52264bd39a896a094340da2b35e5c37a1dcc694f442b398f36290f2d933c1f2b28a4d18ebf5c5f97 SHA512 3733cf321d280bfb265e32b5ed480898a86361b5fd2220a03a1d4ba7e10f5fdc041155444d43b0c67a4e2f51d28652b3d487e3895b7310dc5b4900bcb93411ea
diff --git a/dev-python/python-daemon/python-daemon-2.3.0.ebuild b/dev-python/python-daemon/python-daemon-2.3.0.ebuild
new file mode 100644
index 000000000000..89993f129963
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py