summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-20 08:41:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-20 08:41:03 +0100
commitc915adf64c1415679bfe6b55c95348db2f89202e (patch)
tree4d14cad3390132f7c20f71d055ce4672c160a0c0 /dev-python/python-daemon
parent2d5fd1dd4910d46f935776f1f6f475de11367ef2 (diff)
gentoo auto-resync : 20:07:2022 - 08:41:03
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index e4cee599d52e..b60eafb5127a 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,4 +1,6 @@
AUX python-daemon-2.3.0-fix-py3.10.patch 1137 BLAKE2B 6731a8f43214d3a69bd577b1cfbe1252c21d0f76377026a73a09edcf9f8a99f88e104214ebece37a8a658c458fab0c4970796f46a8b976218062a4b5ab4e4e0f SHA512 5012ad1c3a4b2e88c16e7e3bb64761e9b99a8233e25808aed9e9ddaeaeb9c47b8b3b0884ca927f9d7c36239b84c932f96ef4d84e26cc005f25bc222332f1c4c6
DIST python-daemon-2.3.0.tar.gz 82831 BLAKE2B 6e7fa082a513827283f46044347dfd445633db0d1781a33aa1bc5b14c340da784310ae6bd07d6cf3673cd05cb14a9d090ab51857d26cca52d09bc8c3b195360f SHA512 30bb70821aae720d09032c8c666524fa9a1a486314ffff73eb161231a1f2b954914295b4ad41f9c8529bc045fb6d0f89256bc59f8979a4f8a6698e9bd4d7441a
+DIST python-daemon-2.3.1.tar.gz 82856 BLAKE2B d1ede5fde50f179b0bf3e3ed89bd988469bae1f57667ab601d44452706a84264f55fc9beb89226e5fb1bb6d92f88fc2a5c2497628de16990407a0e01cfbacd84 SHA512 128fd8ac125eac613936668bb555635c8cec576d5c23513210f0956983c70720dd93906adeee581b192b57480a3df93dc1e08f6f7b62e38b2404fa00aba4805a
EBUILD python-daemon-2.3.0-r2.ebuild 915 BLAKE2B d2be9a4fd48cbb0ed62dda6f5e3a131302e39c7c3cfe0123c2f1af15b09f830c7908030f7e072a2a5e69bb9dea4bdee190633429b1b32dbd6c0e0df0406ddfce SHA512 cb748a6ab7418fb0130aa761f3e893ae651f3cb9162edcb2ef24176075bb07b96f08200c9f75e82c153cc8484f21b79c468730f100fe031ba4fed4644c26618f
+EBUILD python-daemon-2.3.1.ebuild 787 BLAKE2B c6d45f6c9bc8dded2e39071d927306803fcd18cf03f8a5e4232670ec7cac7635205a19a1c9eec0ee15a42b8086bd0ea97597f12f1b912d07bef0abaa76ca926b SHA512 de027d7fde09d582f8a7d58f167690762ab0488aacb4e2ddf04cc19375ab2e499cba3c373975e29cecd68d79a223efca0984ebd218c7db48c4131717ea9e29db
MISC metadata.xml 341 BLAKE2B 62d37c28a9bf9e9fc6e2dd9fc5295558eb395dac54a45e548ec7d6738fdebe42053cd2f85b160135fe8fe5828eb065bf7d95b17f3c76697ab6ca2f0e664ffb8b SHA512 83badd112e5e5ed2584cd883abc20b43a18585e7c1d006c4d4861f555e633225f251d7c5b05e2e8f94f74107e32a5eeffcdd3f1265feb463f7c521c7c7141752
diff --git a/dev-python/python-daemon/python-daemon-2.3.1.ebuild b/dev-python/python-daemon/python-daemon-2.3.1.ebuild
new file mode 100644
index 000000000000..61b277f6fec1
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest