summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
commita6764d56b1c85c8272783500983011c143c72d80 (patch)
tree4012d67c099814931c6188b22a6b5eb4e77f1d6a /dev-python/python-daemon
parent38ecaf88ae0891dd2d7f2bdd9a7acdcd45835724 (diff)
gentoo auto-resync : 05:12:2024 - 02:07:17
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-3.1.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index bb62056d2bd5..5a4d5442039e 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,5 +1,7 @@
DIST python_daemon-3.1.0.tar.gz 61947 BLAKE2B d6f24cb72a033401a2eb1149c359ec49e044b0d549ae8ccb337dc60525f3ad80efd8646a50a51e6ba0768a5e8e77a3a5bd5b1a5aea3b54c5546769a5599d49ad SHA512 d7641baba841af8724dd37b66db605d07a62c947f01ff6328c44aca56deaa5a0891b8fe3bbbf5840e16c7080402776676892f105aac900944a8d2921a12edba4
DIST python_daemon-3.1.1.tar.gz 71104 BLAKE2B 56ab3f178233f4fffe64413d34046297f1a136b9e6843e5f90a05e2634bb6cad49dec39ec66d85bf3edd003127ee57a0ed772b192d073e8d7a935956b0992cc2 SHA512 faf074e8ef07b5cda32cbdd66f613d2830569d6a0316b8048e0173b65c45b5472a42a90edacecb811c4cd7daf1d239f898f8a939c4dfb807ef88455f2dc27a9b
+DIST python_daemon-3.1.2.tar.gz 71576 BLAKE2B 605b84271935e5c8bf54aee64f4a4a4dfec06e87acb7d2edd2c7676c67f0b1b933bceec29ab91debad8745e501744cf507f745e1aa0b159f7b600257ed68815c SHA512 3901b9f14f11b8765eb31874fdb9410cbda1425ce70d2702827fe4745b5b8fb93f23e9f71faa6b0ca001745aeea03c186c4e29d973cb12a5912340dae6aa2ee0
EBUILD python-daemon-3.1.0.ebuild 1108 BLAKE2B 51fb219d835e647379633f6e7775b32aaf45d7131c242b29e9daa42902888fbf03cb26ec9ac57bbb38c7323cd34c7dbe1d4158b63ffa80c515104ecaa87b80f0 SHA512 5802763e756bdc549c2f299c2d69314774fdc32dc96f98ff4374926f3633a4dddf7de91f7f4c8316d4b0b8c2ce581fca38e72c791363a308270aa07db849d28a
EBUILD python-daemon-3.1.1.ebuild 1191 BLAKE2B 78a50f4649a648cb3aaa7742ba4ccfd6dd60d0e0a01d7fd34d88ccd734e55ff63c752248f9135f12c66a3ced28102855a71466bdb1e4e844ce059fbff2bc507e SHA512 8ce86bd926935fb3c15393727e16c708c7b9f73cf415b51388365d9817623c7a74b2e633c233a8be41daa044bb55868b93697204341c0597fb70aac76b51e7e7
+EBUILD python-daemon-3.1.2.ebuild 1128 BLAKE2B d8f8f0c5bdc24fcc2b4c27b50d61272f13a1a079eaad339dba90078ac20609b6b2fd51268901f235d65ed8f3728d5d261520a61c58f6a0f2c3c1653edc4bc6a9 SHA512 4b4ff1674eb553f58984540963113043495f900f93ae53d3a12fd9b77a7282a6d46fccf58865476df038658ffd34001a8d425be047910aca4c884c00477ad30e
MISC metadata.xml 341 BLAKE2B 62d37c28a9bf9e9fc6e2dd9fc5295558eb395dac54a45e548ec7d6738fdebe42053cd2f85b160135fe8fe5828eb065bf7d95b17f3c76697ab6ca2f0e664ffb8b SHA512 83badd112e5e5ed2584cd883abc20b43a18585e7c1d006c4d4861f555e633225f251d7c5b05e2e8f94f74107e32a5eeffcdd3f1265feb463f7c521c7c7141752
diff --git a/dev-python/python-daemon/python-daemon-3.1.2.ebuild b/dev-python/python-daemon/python-daemon-3.1.2.ebuild
new file mode 100644
index 000000000000..ebe4f04ad45e
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-3.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="
+ https://pagure.io/python-daemon/
+ https://pypi.org/project/python-daemon/
+"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/lockfile-0.10[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # overengineered logic with NIH deps
+ rm setup.py || die
+ cat > setup.cfg <<-EOF || die
+ [metadata]
+ version = ${PV}
+ description = ${DESCRIPTION}
+ maintainer =
+ long_description =
+ exclude = doc
+ EOF
+
+ # tests for their overengineered setup
+ rm test/test_{setup,util_metadata}.py || die
+}