summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/python-daemon
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-2.2.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index 5ae30671d2a8..87cb05845dbe 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,5 @@
DIST python-daemon-2.1.2.tar.gz 76176 BLAKE2B f8252bb3ee23b9d2a4ac33057df98720708b2a7e10c38c188c537d3c90ad641e33ba73e39f1bbfca10655e2ebd5d550179ed55d09a2f767832fa1d26accc9e21 SHA512 28ae118fd652a0a26524215568df0b16264e3a844640fe47f0a08c45c7a16be1b60d78293c2fc13edfe1402a8b5dcd72ec11101c3b53e5b66f232b7e21d5d346
+DIST python-daemon-2.2.4.tar.gz 80775 BLAKE2B 3f260993a2207e6467db03c456d9f8621d1f3252236b6d49432ff14c1039416db901feb5d405620106d02ae2ea186fd0b10183156f31d17f9f4fa62964fbd333 SHA512 9a7a4e23e126f05e4c1c503f15401cddd758c5f9195c370997060ca1bbfe71cc51d82d3ae16bcf0023c28fa50b0b8d6cd406e515b27725ffa9fec10fde3ed64a
EBUILD python-daemon-2.1.2.ebuild 795 BLAKE2B 91acd4776b431e3db41576b8414e8aabe8b729d88bd91723878ba955c97b0d640abeed6a0bb8a5bf1ebe0a45fbddd0af45644e15f7090032d976176e474db0f8 SHA512 613a5215b2741395ed4b22255fb2d4ef4e4bfe9700b216880997891eb484692b223a77071f07baafbd7111b62f2cd63bb01b6bcb27c0b7f8198473a6ae50f7f3
+EBUILD python-daemon-2.2.4.ebuild 772 BLAKE2B 70edc4ca9768005e51a58a07d56f0de88b16ef9254a311776f8fa968a41900114a0b5d3082d33280817e6600cebc759b99baac8198349e4cb8b14754bee6eb63 SHA512 23d98e63ce7e19d73127cf8fe3697e12a13d5f1413a3efa757f5160227e886c6945596c05e7687c4864cca3d98d88d7eed16153df033ea4d5a6852758a5813bc
MISC metadata.xml 316 BLAKE2B 413934d7b67818ac0d3ddb8c1e5040de2f3008a2e1c01efff6afa4c0aeb6bb849391bdb8730e14091c3efffa47566b831d44cd7728cc9496c6e3bbc7a6c56d97 SHA512 b3b79f6094ec59bc09c2a14e3752edc0722c0e50c9559ac59e6c1355577c1f36ff98ccf6af969d0624b1e6b8b907a7886f6daafb6c0d789a403ec402083b06a4
diff --git a/dev-python/python-daemon/python-daemon-2.2.4.ebuild b/dev-python/python-daemon/python-daemon-2.2.4.ebuild
new file mode 100644
index 000000000000..c056689964c1
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py