summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/python-daemon
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild (renamed from dev-python/python-daemon/python-daemon-2.3.0.ebuild)11
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index a5a09c9cc7ae..27b633ce9ba0 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,3 @@
DIST python-daemon-2.3.0.tar.gz 82831 BLAKE2B 6e7fa082a513827283f46044347dfd445633db0d1781a33aa1bc5b14c340da784310ae6bd07d6cf3673cd05cb14a9d090ab51857d26cca52d09bc8c3b195360f SHA512 30bb70821aae720d09032c8c666524fa9a1a486314ffff73eb161231a1f2b954914295b4ad41f9c8529bc045fb6d0f89256bc59f8979a4f8a6698e9bd4d7441a
-EBUILD python-daemon-2.3.0.ebuild 703 BLAKE2B ca5c70ad2974d56f8ef25402c10d3f3d3fb466130ddbdc4a58a83e0258e15495ca9f02dba9c30bcbb0d92e1753a6a46474bd54022fc91972bb3ddad9a2a7c5f0 SHA512 6af9e517c85331cb412ad92db6b54716c64db0590584229ec8448cdc5ad8ce5abb869df1abb544aad9f180640504ca4e46b50f5fbff5bb70d898c8de3cee73bb
+EBUILD python-daemon-2.3.0-r1.ebuild 865 BLAKE2B 21c7f9270f5121e2bf5d0893b78225bc6d2fafa90c9fca7b7ca6d7df6dd497b061871b4b66ef97a13719008869329853aa3ba59836fa83ff9e3058e0dd0c78a7 SHA512 c23e13f933c6136853e758a19a68d0a22e113148e1a368b9735c2bc409a88843328ddc7d644f9a19f954878af79c3fac940951101e2e28a2b864f99aa15b6381
MISC metadata.xml 340 BLAKE2B 8b44be0af694459080c54e9611780e3c5b1802a54702f38d52264bd39a896a094340da2b35e5c37a1dcc694f442b398f36290f2d933c1f2b28a4d18ebf5c5f97 SHA512 3733cf321d280bfb265e32b5ed480898a86361b5fd2220a03a1d4ba7e10f5fdc041155444d43b0c67a4e2f51d28652b3d487e3895b7310dc5b4900bcb93411ea
diff --git a/dev-python/python-daemon/python-daemon-2.3.0.ebuild b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
index dd172f9cc2ec..ebd89363d0b2 100644
--- a/dev-python/python-daemon/python-daemon-2.3.0.ebuild
+++ b/dev-python/python-daemon/python-daemon-2.3.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..9} pypy3 )
inherit distutils-r1
@@ -29,4 +29,11 @@ BDEPEND="
)
"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fix for >=testtools-2.5.0
+ sed -e 's/testtools.helpers.safe_hasattr/hasattr/' \
+ -i test/test_metadata.py || die
+ distutils-r1_src_prepare
+}