summaryrefslogtreecommitdiff
path: root/dev-python/python-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-26 04:04:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-26 04:04:26 +0100
commitd0349ca0f4903608beca459a9db2068dab9fa6ea (patch)
treea69bc9c4a75f35ecabd3909a181128faf8c0e75b /dev-python/python-daemon
parentb11a5614cb96e70e116581c98abf286c2cf694ca (diff)
gentoo auto-resync : 26:10:2024 - 04:04:26edge
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest2
-rw-r--r--dev-python/python-daemon/python-daemon-3.1.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index f438b1110afc..5da43c8652bc 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1,3 +1,5 @@
DIST python-daemon-2.3.2.tar.gz 83127 BLAKE2B bce00867850e8451bcaf5a51864bdd751fa3b5e7be8ae1d36d724a915680713fc66c0fc6c8499bce03e0eb86465f5806fb8645376e600b8eac579fee3c24a087 SHA512 d9f6e6c376a496fae96bd9efed0a56d00a137617a3d1d5ef74802ef176bc813bb1d49bbb9164cdbec03213529f944b32b257bcc64283abfa4a3522ff00826bfd
+DIST python_daemon-3.1.0.tar.gz 61947 BLAKE2B d6f24cb72a033401a2eb1149c359ec49e044b0d549ae8ccb337dc60525f3ad80efd8646a50a51e6ba0768a5e8e77a3a5bd5b1a5aea3b54c5546769a5599d49ad SHA512 d7641baba841af8724dd37b66db605d07a62c947f01ff6328c44aca56deaa5a0891b8fe3bbbf5840e16c7080402776676892f105aac900944a8d2921a12edba4
EBUILD python-daemon-2.3.2.ebuild 796 BLAKE2B 745ad90d0216cf8715aa777167b74d13ca5115e62b56a7e0d0e276745cc39e0c3320452afeb435b2e73678b7b716f781856754a2774e39f5a2c97b83a39c5c26 SHA512 cef8d79be8c861ca00faa17bbd8216ecdd6a4b1fd0c4f04bd44b41392677bdbab29fc6ab048086407ce47c78cc8e3151f04be107382b5e7dfa3e49956ed9a085
+EBUILD python-daemon-3.1.0.ebuild 1112 BLAKE2B ff590f6d8950216528a0d03f73666aaf52b766979cd176309f457f3a9a84bd16719e5a7403fcc18a2d79559d36d38056fa555587a6403ca0c78d5b4276ee7f20 SHA512 ec8f5caaba4267082f42173aed3e55df8916ee035cca899438f36f56afd296b90d1055d3c149f3266c38f5c6161e7120564942cd42cc353bbd5dfa6fb5601bc3
MISC metadata.xml 341 BLAKE2B 62d37c28a9bf9e9fc6e2dd9fc5295558eb395dac54a45e548ec7d6738fdebe42053cd2f85b160135fe8fe5828eb065bf7d95b17f3c76697ab6ca2f0e664ffb8b SHA512 83badd112e5e5ed2584cd883abc20b43a18585e7c1d006c4d4861f555e633225f251d7c5b05e2e8f94f74107e32a5eeffcdd3f1265feb463f7c521c7c7141752
diff --git a/dev-python/python-daemon/python-daemon-3.1.0.ebuild b/dev-python/python-daemon/python-daemon-3.1.0.ebuild
new file mode 100644
index 000000000000..a0b03d674d2a
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-3.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="
+ https://pagure.io/python-daemon/
+ https://pypi.org/project/python-daemon/
+"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/lockfile-0.10[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # overengineered logic with NIH deps
+ rm setup.py || die
+ cat > setup.cfg <<-EOF || die
+ [metadata]
+ version = ${PV}
+ description = ${DESCRIPTION}
+ maintainer =
+ long_description =
+ EOF
+
+ # tests for their overengineered setup
+ rm test/test_{setup,util_metadata}.py || die
+}