summaryrefslogtreecommitdiff
path: root/dev-python/python-ctags/python-ctags-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/python-ctags/python-ctags-1.5.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/python-ctags/python-ctags-1.5.0.ebuild')
-rw-r--r--dev-python/python-ctags/python-ctags-1.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-ctags/python-ctags-1.5.0.ebuild b/dev-python/python-ctags/python-ctags-1.5.0.ebuild
new file mode 100644
index 000000000000..ad9ef15a077b
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags:="
+
+distutils_enable_tests setup.py