summaryrefslogtreecommitdiff
path: root/dev-python/python-ctags/python-ctags-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-ctags/python-ctags-1.2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-ctags/python-ctags-1.2.4.ebuild')
-rw-r--r--dev-python/python-ctags/python-ctags-1.2.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-ctags/python-ctags-1.2.4.ebuild b/dev-python/python-ctags/python-ctags-1.2.4.ebuild
new file mode 100644
index 000000000000..f225cc435abd
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ esetup.py test
+}