summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/python-cstruct
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest3
-rw-r--r--dev-python/python-cstruct/metadata.xml11
-rw-r--r--dev-python/python-cstruct/python-cstruct-1.7.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
new file mode 100644
index 000000000000..1c4cd7db9bf5
--- /dev/null
+++ b/dev-python/python-cstruct/Manifest
@@ -0,0 +1,3 @@
+DIST cstruct-1.7.tar.gz 8768 BLAKE2B 9b66c1cadb5c32965fe29de4e1f3bf2a3f00695d3c6ced4cf28dc85d8580b7fbad626633f9672e25521e5e2fde93049a953c6fe089fb154aa51c82f080427121 SHA512 c3a612ec4c5778801a9d506a49b8817b56fb99e1788c4894ce753178aa4472cedff3b842fe1f40a925e76efbf737166384c279ed0f697655d6ea8d5f1581973a
+EBUILD python-cstruct-1.7.ebuild 626 BLAKE2B fc64c05cf6ec83840e1193bf516263833194c09321b16c012a7f7c643b524941b30ca4b3525dbd8ab57403ae6832e48af7616dc0700f6392c678e32330890cf9 SHA512 916f4d0912959f559fdb28b4d6b99f9a117026599a9ed0d74248eff8079c3ae0f3c928404d579464583b620830aa41d244c4687282c20d31fd84cd34c529cbd3
+MISC metadata.xml 352 BLAKE2B a2478767166958184fcd375f35b563a7a8e55de1c27068cc0959eab9fe6ace8fd1d42e3db862114e73bf7bd30181a09dd0bb3342ed48bf5db4496a882751197f SHA512 979cb550fb49246beeb8dcc2adc4119af81d80c7ccfe2ad21be0eaf2ae0042ac0c38a974366686104038ba5ba960910464a64b86782cf12156e44bf0faa6b2d2
diff --git a/dev-python/python-cstruct/metadata.xml b/dev-python/python-cstruct/metadata.xml
new file mode 100644
index 000000000000..7570280ec6e6
--- /dev/null
+++ b/dev-python/python-cstruct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">andreax79/python-cstruct</remote-id>
+ <remote-id type="pypi">cstruct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cstruct/python-cstruct-1.7.ebuild b/dev-python/python-cstruct/python-cstruct-1.7.ebuild
new file mode 100644
index 000000000000..942424ff8aa5
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN#python-}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct https://pypi.org/project/cstruct/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README.md )
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTHON}"
+}