summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/python-cstruct
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest2
-rw-r--r--dev-python/python-cstruct/python-cstruct-1.8.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 5dd04b349577..62190646b617 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1,3 +1,5 @@
DIST cstruct-1.7.tar.gz 8768 BLAKE2B 9b66c1cadb5c32965fe29de4e1f3bf2a3f00695d3c6ced4cf28dc85d8580b7fbad626633f9672e25521e5e2fde93049a953c6fe089fb154aa51c82f080427121 SHA512 c3a612ec4c5778801a9d506a49b8817b56fb99e1788c4894ce753178aa4472cedff3b842fe1f40a925e76efbf737166384c279ed0f697655d6ea8d5f1581973a
+DIST python-cstruct-1.8.tar.gz 9911 BLAKE2B 88e091274495034c05d66e4ac808b3884a766017da92bb661cb6c90111cdb5e0d11f93a83e59be74acba9ba408c37b8cbaac88a1bb4fbbed120a2d0aaccd0979 SHA512 9ca9abf388965af06be6ab455652c60aaf2738a08bd7fcc32a8be57c19b2d705784618fd108bfa727a1c05c5749f761d698adc6550bffa1ebcaaedadd7d56a62
EBUILD python-cstruct-1.7.ebuild 609 BLAKE2B 5b5e7b7111947565bb9431a6d920e85010477fcee7e72513039bc1085afcaae9968631637bebd4d45ca6e889d2d8921c0f042aeae84a32754e8a2ef6d1873cee SHA512 f1761b561c51879a772d9a9039c9c023849e26064b41506b035a266a5dd5c81fd64405222bcb90e47708ee6d64ac9df0d1038ca0daed950858cbc83b459337df
+EBUILD python-cstruct-1.8.ebuild 673 BLAKE2B 1722cf529e39f1f7b629682c9c2304a625dc677feddf6087b5572f44d0c6dcc2ab3ffb2aaac242c894f645946575046863723c0ff6fb564e9648a8ddb70580c8 SHA512 32ad4f7cdf357f6d9ec624ada03fa8680003a1f332333d5984952ab7d5bcd52be07fa263d0b8ab58410ae62596a6e27d017ee4a6f72ec2e4c3c6bc75120f53b7
MISC metadata.xml 352 BLAKE2B a2478767166958184fcd375f35b563a7a8e55de1c27068cc0959eab9fe6ace8fd1d42e3db862114e73bf7bd30181a09dd0bb3342ed48bf5db4496a882751197f SHA512 979cb550fb49246beeb8dcc2adc4119af81d80c7ccfe2ad21be0eaf2ae0042ac0c38a974366686104038ba5ba960910464a64b86782cf12156e44bf0faa6b2d2
diff --git a/dev-python/python-cstruct/python-cstruct-1.8.ebuild b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
new file mode 100644
index 000000000000..a7870977d0da
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=manual
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct https://pypi.org/project/cstruct/"
+SRC_URI="https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# define setuptools dep manually to avoid warning
+# setup.py contains entry_points, but it's an empty string
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.md )
+
+distutils_enable_tests setup.py