summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/python-cstruct
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest6
-rw-r--r--dev-python/python-cstruct/metadata.xml4
-rw-r--r--dev-python/python-cstruct/python-cstruct-2.1.ebuild (renamed from dev-python/python-cstruct/python-cstruct-1.8.ebuild)6
3 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 7ca9d83a0fdb..183e97890f91 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1,3 +1,3 @@
-DIST python-cstruct-1.8.tar.gz 9911 BLAKE2B 88e091274495034c05d66e4ac808b3884a766017da92bb661cb6c90111cdb5e0d11f93a83e59be74acba9ba408c37b8cbaac88a1bb4fbbed120a2d0aaccd0979 SHA512 9ca9abf388965af06be6ab455652c60aaf2738a08bd7fcc32a8be57c19b2d705784618fd108bfa727a1c05c5749f761d698adc6550bffa1ebcaaedadd7d56a62
-EBUILD python-cstruct-1.8.ebuild 481 BLAKE2B f3c5d2f6265999fc2e062927c9edffae52197138df77d9182e69ae959c3d9af86bf120a074bbb8591fb1b0025a3d3bc51a86b784f071d97084b692250325d6b8 SHA512 cfc3660c03a80bf1d8e67609b31cabe74cd484d0b8fd7b7bf60fae1aba420e1a030fcb65fcc09c5a13e61cfb38f6bfc73566fbbe6366e0ea4b9da441c353547b
-MISC metadata.xml 353 BLAKE2B a5f07040a6d4cd015af11129548ba98bd63e66845647477a9327eceede3b0f66ebf503dab421ad72ac93ab7944eba141983cf3c69da07d7acd8b10c035fda5e9 SHA512 165fbc46aa7e400a661aabbcdc195013f193c045a2e3ebc5444980c0c91d5010b5a9005a9629eeee65223fed384c1f0d7ef2eeeefc90ecb4eeca618b3f506465
+DIST python-cstruct-2.1.tar.gz 17298 BLAKE2B 9acc10f0d386c4413634945fc94b3e44210617c408ee18cf6533f70e7d64c609d463e9beceeea7c79b125e0bf0ab67a720d9ff98f45b4e7ce1f51d9280b55733 SHA512 c56c87d291c4aa2afcfdbcbbc19c03ec634b6fb0dcde9d516ef2a9079be2fea52a053c47cd20dfc0fe6537ac90939364da659d8eb4763069a9990681207d432c
+EBUILD python-cstruct-2.1.ebuild 479 BLAKE2B 29cecfe02f3aff90a7d9cf8ce888fda2b28edaed9a81463d7b15fc0b16c35d1aedd1da6cd88054353691e4d101e4034832c4f3f776ae4dc696b7e4da0ac0cb1f SHA512 1928a9f672f070c5093651b2cfdb0804ceffd70689a637b5154d6009ad2df4030773bada4c420a610ef7247713e0a95c24bb9b40c00d66eab40670c04ef62577
+MISC metadata.xml 454 BLAKE2B 5138bc275b0b9e18cab52fb309283c6b6dab8be5dcc3c86dd6526f350b216c68bc94dd2aabc7a33a4879c23165924563396c6d5991f5c702a12e184067d25cdb SHA512 bb259a25444029d8ea63577f0576ab283282298d27987e276bf4eb6d4ef00853ed019ad199830e9bb4e738f9a151feb55d53e76917508f1033c2b3ecd246276f
diff --git a/dev-python/python-cstruct/metadata.xml b/dev-python/python-cstruct/metadata.xml
index 44b8a2c02287..d1468dcb4ec3 100644
--- a/dev-python/python-cstruct/metadata.xml
+++ b/dev-python/python-cstruct/metadata.xml
@@ -4,6 +4,10 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="github">andreax79/python-cstruct</remote-id>
<remote-id type="pypi">cstruct</remote-id>
diff --git a/dev-python/python-cstruct/python-cstruct-1.8.ebuild b/dev-python/python-cstruct/python-cstruct-2.1.ebuild
index 91bfd95f8251..ccdcbbfbf89e 100644
--- a/dev-python/python-cstruct/python-cstruct-1.8.ebuild
+++ b/dev-python/python-cstruct/python-cstruct-2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="C-style structs for Python"
@@ -16,4 +16,4 @@ KEYWORDS="~amd64 ~x86"
DOCS=( README.md )
-distutils_enable_tests setup.py
+distutils_enable_tests pytest