summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct/python-cstruct-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
commit14a74a5f982f25582974c2ee235027a041aec36d (patch)
treedc57c37e535d9d67af9a5034c4748ec3698923b9 /dev-python/python-cstruct/python-cstruct-5.2.ebuild
parentb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (diff)
gentoo auto-resync : 25:11:2022 - 07:12:04
Diffstat (limited to 'dev-python/python-cstruct/python-cstruct-5.2.ebuild')
-rw-r--r--dev-python/python-cstruct/python-cstruct-5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/python-cstruct-5.2.ebuild b/dev-python/python-cstruct/python-cstruct-5.2.ebuild
new file mode 100644
index 000000000000..e1a88b9460d4
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest